PAT-1051 Pop Sequence

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/eric4784510/article/details/82013757

1051 Pop Sequence(25 分)

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO

  判断是否是合法的出栈序列,模拟堆栈运行即可。

#include<stdio.h>
#include<algorithm>
#include<stack>
using namespace std;

int main(){
	int m,n,k;
	scanf("%d %d %d",&m,&n,&k);
	int t[1005];
	bool v[1005];
	for(int i=0;i<k;i++){
		for(int j=0;j<n;j++){
			scanf("%d",t+j);
		}
		fill(v+1,v+n+1,false);
		stack<int> s;int tag=true;
		for(int j=0;j<n;j++){

			if(s.size()>0&&s.top()==t[j]){	
				s.pop();
			}else{
				if(v[t[j]]==true)
				{printf("NO\n");tag=0;break;}

				if(s.size()>=m)
				{printf("NO\n");tag=0;break;}

				v[t[j]]=true;
				for(int a=1;a<t[j];a++){
					if(!v[a]){
						v[a]=true;
						s.push(a);
					}
				}
				if(s.size()>m-1)
				{printf("NO\n");tag=0;break;}
			}
		}
		if(tag)
			printf("YES\n");
	}

	return 0;
}

猜你喜欢

转载自blog.csdn.net/eric4784510/article/details/82013757