Pop Sequence

Pop Sequence (25 分)

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and Nis 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO

#include<iostream>
#include<stack>

using namespace std;
int main() {
    int m, n, k;
    cin >> m >> n >> k;
    int b[1000];
    for (int i = 0; i < k; i++) {
        int a[1000];
        for (int j = 0; j < n; j++) {
        cin >> a[j];
        b[j] = j + 1;
        }
        stack<int> s;
        s.push(0);
        int flag = 0;
        int no = 0;
        for (int i = 0,t=0; i < n; i++) {
            while (a[i] != s.top()) {
                if (flag == m) {
                    cout << "NO" << endl;
                    no = 1;
                    break;
                }
                s.push(b[t++]);
                flag++;
            }
            if (no) break;
            while (a[i] == s.top()) {
                s.pop();
                flag--;
            }
                    }
        s.pop();
        if (flag == 0&&s.empty()&&!no)
            cout << "YES" << endl;
        else if(!no)
            cout << "NO" << endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/lannister_awalys_pay/article/details/83245296