01背包(一维空间优化)

http://acm.hdu.edu.cn/showproblem.php?pid=1171

Big Event in HDU

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 58312    Accepted Submission(s): 19584


Problem Description
Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer College and Software College in 2002.
The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds).
 
Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different.
A test case starting with a negative integer terminates input and this test case is not to be processed.
 
Output
For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.
 
Sample Input
2 10 1 20 1 3 10 1 20 2 30 1 -1
 
Sample Output
20 10 40 40
 
Author
lcy
 根据二维01背包对于第一维只用到了f[i-1]和f[i],所以可以将第一维去掉,使用滚动数组。
https://www.cnblogs.com/zyacmer/p/9961710.html
//#include <bits/stdc++.h>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <iostream>
#include <algorithm>
#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
#include <stdio.h>
#include <queue>
#include <stack>;
#include <map>
#include <set>
#include <string.h>
#include <vector>
#define ME(x , y) memset(x , y , sizeof(x))
#define SF(n) scanf("%d" , &n)
#define rep(i , n) for(int i = 0 ; i < n ; i ++)
#define INF  0x3f3f3f3f
#define mod 1000000007
#define PI acos(-1)
using namespace std;
typedef long long ll ;
int dp[255555] ;
int w[5009];

int main()
{
    int n ;
    while(~scanf("%d" , &n) && n > 0)
    {
        int l = 1 , sum = 0 ;
        memset(dp , 0 , sizeof(dp));
        for(int i = 0 ; i < n ; i++)
        {
            int v , num ;
            scanf("%d%d" , &v , &num);
            while(num--)
            {
                w[l++] = v ;
                sum += v ;
            }
        }
        for(int i = 1 ; i < l ; i++)
        {
            for(int j = sum/2 ; j >=w[i] ; j--)
            {
                dp[j] = max(dp[j] , dp[j-w[i]]+w[i]);
            }
        }
        cout << sum - dp[sum/2] << " " << dp[sum/2] << endl ;

    }

    return 0;
}

猜你喜欢

转载自www.cnblogs.com/nonames/p/11671645.html