hdu1253

胜利大逃亡

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 42192    Accepted Submission(s): 14674


Problem Description
Ignatius被魔王抓走了,有一天魔王出差去了,这可是Ignatius逃亡的好机会.

魔王住在一个城堡里,城堡是一个A*B*C的立方体,可以被表示成A个B*C的矩阵,刚开始Ignatius被关在(0,0,0)的位置,离开城堡的门在(A-1,B-1,C-1)的位置,现在知道魔王将在T分钟后回到城堡,Ignatius每分钟能从一个坐标走到相邻的六个坐标中的其中一个.现在给你城堡的地图,请你计算出Ignatius能否在魔王回来前离开城堡(只要走到出口就算离开城堡,如果走到出口的时候魔王刚好回来也算逃亡成功),如果可以请输出需要多少分钟才能离开,如果不能则输出-1.


 

Input
输入数据的第一行是一个正整数K,表明测试数据的数量.每组测试数据的第一行是四个正整数A,B,C和T(1<=A,B,C<=50,1<=T<=1000),它们分别代表城堡的大小和魔王回来的时间.然后是A块输入数据(先是第0块,然后是第1块,第2块......),每块输入数据有B行,每行有C个正整数,代表迷宫的布局,其中0代表路,1代表墙.(如果对输入描述不清楚,可以参考Sample Input中的迷宫描述,它表示的就是上图中的迷宫)

特别注意:本题的测试数据非常大,请使用scanf输入,我不能保证使用cin能不超时.在本OJ上请使用Visual C++提交.
 

Output
对于每组测试数据,如果Ignatius能够在魔王回来前离开城堡,那么请输出他最少需要多少分钟,否则输出-1.
 

Sample Input
 
  
1 3 3 4 20 0 1 1 1 0 0 1 1 0 1 1 1 1 1 1 1 1 0 0 1 0 1 1 1 0 0 0 0 0 1 1 0 0 1 1 0
 

Sample Output
 
  
11
 

Author

Ignatius.L


简单bfs  有一个剪枝

注意他给的 A相当于 z坐标

#include<bits/stdc++.h>
using namespace std;
const int maxn = 55;
struct node{
	int x, y, z;
	int step;
	node(){
	}
	node(int x,int y,int z,int step)
	{
		this->x = x;
		this->y = y;
		this->z = z;
		this->step = step;
	}
};
int mp[maxn][maxn][maxn];
int visit[maxn][maxn][maxn];
int A, B, C, T;
int dir[6][3] = {{1,0,0},{-1,0,0},{0,1,0},{0,-1,0},{0,0,1},{0,0,-1}}; 
int bfs()
{
	queue<node> q;
	q.push(node(0,0,0,0));
	visit[0][0][0] = 1;
	
	while(!q.empty())
	{
		node t = q.front();
		q.pop();
		if(A + B + C - 3 - t.step > T) continue ;
		
		if(t.x == B-1 && t.y == C-1 && t.z == A-1) return t.step;
		
		for(int i = 0;i < 6;i ++)
		{
			int dx = t.x + dir[i][0];
			int dy = t.y + dir[i][1];
			int dz = t.z + dir[i][2];
			
			if(dx < 0 || dy < 0 || dz < 0 || dx >= B || dy >= C || dz >= A || visit[dz][dx][dy] || mp[dz][dx][dy] == 1) continue;
			
			q.push(node(dx,dy,dz,t.step + 1));
			visit[dz][dx][dy] = 1;
		}
		
	}
	
	return -1;
}
int main()
{
	int t;
	scanf("%d",&t);
	while(t --)
	{
		scanf("%d%d%d%d",&A,&B,&C,&T);
		memset(visit,0,sizeof(visit));
		
		for(int i = 0;i < A;i ++)
		{
			for(int j = 0;j < B;j ++)
			{
				for(int k = 0;k < C;k ++)
				scanf("%d",&mp[i][j][k]);
			}
		}
		
		cout << bfs() << endl;
	}
	return 0;
} 


猜你喜欢

转载自blog.csdn.net/soul_97/article/details/80246937
今日推荐