bfs练习 hdu1253胜利大逃亡

Problem Description
Ignatius被魔王抓走了,有一天魔王出差去了,这可是Ignatius逃亡的好机会.

魔王住在一个城堡里,城堡是一个ABC的立方体,可以被表示成A个B*C的矩阵,刚开始Ignatius被关在(0,0,0)的位置,离开城堡的门在(A-1,B-1,C-1)的位置,现在知道魔王将在T分钟后回到城堡,Ignatius每分钟能从一个坐标走到相邻的六个坐标中的其中一个.现在给你城堡的地图,请你计算出Ignatius能否在魔王回来前离开城堡(只要走到出口就算离开城堡,如果走到出口的时候魔王刚好回来也算逃亡成功),如果可以请输出需要多少分钟才能离开,如果不能则输出-1.
在这里插入图片描述

Input
输入数据的第一行是一个正整数K,表明测试数据的数量.每组测试数据的第一行是四个正整数A,B,C和T(1<=A,B,C<=50,1<=T<=1000),它们分别代表城堡的大小和魔王回来的时间.然后是A块输入数据(先是第0块,然后是第1块,第2块…),每块输入数据有B行,每行有C个正整数,代表迷宫的布局,其中0代表路,1代表墙.(如果对输入描述不清楚,可以参考Sample Input中的迷宫描述,它表示的就是上图中的迷宫)

特别注意:本题的测试数据非常大,请使用scanf输入,我不能保证使用cin能不超时.在本OJ上请使用Visual C++提交.

Output
对于每组测试数据,如果Ignatius能够在魔王回来前离开城堡,那么请输出他最少需要多少分钟,否则输出-1.

Sample Input
1
3 3 4 20
0 1 1 1
0 0 1 1
0 1 1 1
1 1 1 1
1 0 0 1
0 1 1 1
0 0 0 0
0 1 1 0
0 1 1 0

Sample Output
11

要求最短路径,用bfs合适,套模版。

//
//  main.cpp
//  hdu1253bfs
//
//  Created by zhan_even on 2018/11/24.
//  Copyright © 2018年 zhan_even. All rights reserved.
//

#include <iostream>
#include <queue>
using namespace std;
const int N = 55;

int map[N][N][N];
int dir[6][3]={{1,0,0}, {-1,0,0}, {0,1,0}, {0,-1,0}, {0,0,1}, {0,0,-1}}; //移动方向
int a,b,c,t,ans;


struct Node
{
    int x,y,z,step;
};



int bfs(Node start){
    queue<Node> q;
    Node cur, next;
    if(start.x==a-1&&start.y==b-1&&start.z==c-1){//考虑起点和终点相同的情况
        return 0;
    }

    start.step=0;
    map[start.x][start.y][start.z]=1;
    q.push(start);
    while (!q.empty()) {
        cur = q.front();//取首部元素
        q.pop();
        for (int i = 0; i < 6; i++) {
            next.x=cur.x+dir[i][0];
            next.y=cur.y+dir[i][1];
            next.z=cur.z+dir[i][2];
            if (next.x == a-1 && next.y == b-1 && next.z == c-1 ) //写一个就是终点
                return cur.step+1;
            if(next.x >= 0 && next.x < a && next.y >= 0 && next.y < b && next.z >= 0 &&  next.z<c)
                if(map[next.x][next.y][next.z]!=1){
                    map[next.x][next.y][next.z]=1;
                    next.step=cur.step+1;
                    q.push(next); //把next放入队列中
                }
        }
    }
    return -1;
    
}


int main(int argc, const char * argv[]) {
    int num,i,j,k;
    Node start;
    scanf("%d", &num);
    while (num--) {
        scanf("%d %d %d %d",&a,&b,&c,&t);
        memset(map,0,sizeof(map));
        for (i = 0; i < a; i++) //输入迷宫
            for (j = 0; j < b; j++)
                for (k = 0; k< c; k++)
                    scanf("%d", &map[i][j][k]);
        if (a + b + c - 3 > t){
            printf("-1\n");
            continue;
        }
        if(map[a-1][b-1][c-1]==1){
            printf("-1\n");
            continue;
        }
        else{
            start.x=0;
            start.y=0;
            start.z=0;
            ans = bfs(start);
            if(ans >= 0 && ans <= t)
                printf("%d\n",ans);
            
            else
                printf("-1\n");
        }
        
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_41568105/article/details/84453933