还是畅通工程//HDU - 1233//kruskal

还是畅通工程//HDU - 1233//kruskal


题目

某省调查乡村交通状况,得到的统计表中列出了任意两村庄间的距离。省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可),并要求铺设的公路总长度为最小。请计算最小的公路总长度。
Input
测试输入包含若干测试用例。每个测试用例的第1行给出村庄数目N ( < 100 );随后的N(N-1)/2行对应村庄间的距离,每行给出一对正整数,分别是两个村庄的编号,以及此两村庄间的距离。为简单起见,村庄从1到N编号。
当N为0时,输入结束,该用例不被处理。
Output
对每个测试用例,在1行里输出最小的公路总长度。
Sample Input
3
1 2 1
1 3 2
2 3 4
4
1 2 1
1 3 4
1 4 1
2 3 3
2 4 2
3 4 5
0
Sample Output
3
5

链接:https://vjudge.net/contest/351234#problem/I

思路

kruskal算法的模板题(最小生成树)。

代码

#include <iostream>//https://vjudge.net/contest/351234#problem/I
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

struct edge{
    int u,v,cost;
};
edge es[10100];
int n,m;
int root[200];
bool cmp(edge e1,edge e2){            //直接判断cost
    return e1.cost<e2.cost;
}
void init(){                           //初始化并查集
    for(int i=1;i<=n;i++){
        root[i]=i;
    }
    return;
}

int findx(int x){                       //查找操作
    if(root[x]==x)
        return x;
    else{
        return root[x]=findx(root[x]);
    }
}

void unite(int x,int y){                 //合并操作
    x=findx(x);
    y=findx(y);
    if(x!=y)
        root[x]=y;
    return;
}

bool same(int x,int y){                    //判断两根是否相等
    return findx(x)==findx(y);
}

int kruskal(){                             //kruskal算法
    sort(es+1,es+m+1,cmp);
    init();
    int res=0;
    for(int i=1;i<=m;i++){
        edge e = es[i];
        if(!same(e.u,e.v)){                 //两根不等才合并
            unite(e.u,e.v);
            res += e.cost;
        }
    }
    return res;
}
int main()
{
    while(scanf("%d",&n)!=EOF&&n){
        m = n*(n-1)/2;
        for(int i=1;i<=m;i++){
            cin>>es[i].u>>es[i].v>>es[i].cost;
        }
        int ans=kruskal();
        cout<<ans<<endl;
    }
    return 0;
}

注意

查找操作不要用迭代,会T,用递归。

发布了24 篇原创文章 · 获赞 9 · 访问量 552

猜你喜欢

转载自blog.csdn.net/salty_fishman/article/details/103950623