usaco6.5.5 Checker Challenge

一 原题

Checker Challenge

Examine the 6x6 checkerboard below and note that the six checkers are arranged on the board so that one and only one is placed in each row and each column, and there is never more than one in any diagonal. (Diagonals run from southeast to northwest and southwest to northeast and include all diagonals, not just the major two.)

          Column
    1   2   3   4   5   6
  -------------------------
1 |   | O |   |   |   |   |
  -------------------------
2 |   |   |   | O |   |   |
  -------------------------
3 |   |   |   |   |   | O |
  -------------------------
4 | O |   |   |   |   |   |
  -------------------------
5 |   |   | O |   |   |   |
  -------------------------
6 |   |   |   |   | O |   |
  -------------------------

The solution shown above is described by the sequence 2 4 6 1 3 5, which gives the column positions of the checkers for each row from 1 to 6:

ROW 1 2 3 4 5 6
COLUMN 2 4 6 1 3 5

This is one solution to the checker challenge. Write a program that finds all unique solution sequences to the Checker Challenge (with ever growing values of N). Print the solutions using the column notation described above. Print the first three solutions in numerical order, as if the checker positions form the digits of a large number, and then a line with the total number of solutions.

Special note: the larger values of N require your program to be especially efficient. Do not precalculate the value and print it (or even find a formula for it); that's cheating. Work on your program until it can solve the problem properly. If you insist on cheating, your login to the USACO training pages will be removed and you will be disqualified from all USACO competitions. YOU HAVE BEEN WARNED.

TIME LIMIT: 1 CPU second

PROGRAM NAME: checker

INPUT FORMAT

A single line that contains a single integer N (6 <= N <= 13) that is the dimension of the N x N checkerboard.

SAMPLE INPUT (file checker.in)

6

OUTPUT FORMAT

The first three lines show the first three solutions found, presented as N numbers with a single space between them. The fourth line shows the total number of solutions found.

SAMPLE OUTPUT (file checker.out)

2 4 6 1 3 5
3 6 2 5 1 4
4 1 5 2 6 3
4

二 分析

K皇后问题(K<=13)


三 代码

运行结果:

USER: Qi Shen [maxkibb3]
TASK: checker
LANG: C++

Compiling...
Compile: OK

Executing...
   Test 1: TEST OK [0.000 secs, 4296 KB]
   Test 2: TEST OK [0.000 secs, 4296 KB]
   Test 3: TEST OK [0.000 secs, 4296 KB]
   Test 4: TEST OK [0.000 secs, 4296 KB]
   Test 5: TEST OK [0.000 secs, 4296 KB]
   Test 6: TEST OK [0.028 secs, 4296 KB]
   Test 7: TEST OK [0.140 secs, 4296 KB]
   Test 8: TEST OK [0.840 secs, 4296 KB]

All tests OK.

YOUR PROGRAM ('checker') WORKED FIRST TIME! That's fantastic -- and a rare thing. Please accept these special automated congratulations.


AC代码:

/*
ID:maxkibb3
LANG:C++
PROB:checker
*/

#include <cstdio>
#include <vector>

using namespace std;

// #define local

const int maxn = 14;

int n, cnt;
bool r[maxn], d1[maxn << 2], d2[maxn << 2];
vector<int> trace;

void dfs(int x) {
    if(x == n + 1) {
        cnt++;
        if(cnt <= 3) {
            printf("%d", trace[0]);
            for(int i = 1; i < n; i++) printf(" %d", trace[i]);
            printf("\n");
        }
        return;
    }
    for(int i = 1; i <= n; i++) {
        if(r[i]) continue;
        if(d1[x - i + n]) continue;
        if(d2[x + i]) continue;
        r[i] = true;
        d1[x - i + n] = true;
        d2[x + i] = true;
        trace.push_back(i);
        dfs(x + 1);
        trace.pop_back();
        r[i] = false;
        d1[x - i + n] = false;
        d2[x + i] = false;
    }
}

int main() {
    #ifndef local
        freopen("checker.in", "r" ,stdin);
        freopen("checker.out", "w", stdout);
    #endif
    scanf("%d", &n);
    dfs(1);
    printf("%d\n", cnt);
    return 0;
}


猜你喜欢

转载自blog.csdn.net/max_kibble/article/details/79368027