PAT 甲级 A1056

1056 Mice and Rice (25分)

题目描述

Mice and Rice is the name of a programming contest in which each programmer must write a piece of code to control the movements of a mouse in a given map. The goal of each mouse is to eat as much rice as possible in order to become a FatMouse.

First the playing order is randomly decided for N​P programmers. Then every N​G programmers are grouped in a match. The fattest mouse in a group wins and enters the next turn. All the losers in this turn are ranked the same. Every N​G​​winners are then grouped in the next match until a final winner is determined.

For the sake of simplicity, assume that the weight of each mouse is fixed once the programmer submits his/her code. Given the weights of all the mice and the initial playing order, you are supposed to output the ranks for the programmers.

输入格式

Each input file contains one test case. For each case, the first line contains 2 positive integers: N​Pand NG(≤1000), the number of programmers and the maximum number of mice in a group, respectively. If there are less than NG
​​mice at the end of the player’s list, then all the mice left will be put into the last group. The second line contains N​P distinct non-negative numbers W​i(i=0,⋯,N​P−1) where each W​i is the weight of the i-th mouse respectively. The third line gives the initial playing order which is a permutation of 0,⋯,N​P−1(assume that the programmers are numbered from 0 to N​P−1). All the numbers in a line are separated by a space.

输出格式

For each test case, print the final ranks in a line. The i-th number is the rank of the i-th programmer, and all the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:

11 3
25 18 0 46 37 3 19 22 57 56 10
6 0 8 7 10 5 9 1 4 2 3

Sample Output:

5 5 5 2 5 5 5 3 1 3 5

总结

这题想了半天想不出来,一直想的是用树来做但不知道代码怎么写QWQ。后来看了下书才发现排名和组号居然有着神奇的+1关系(给跪了)。发现了这个规律代码就好写多了,直接用队列来模拟序号对应老鼠的排名。稍微注意一下题目给的初始序列,初始老鼠们的重量序列应该是19 25 57 22 10 3 56 18 37 0 46,这个序列的排名结果竟然和25 18 0 46 37 3 19 22 57 56 10这个一样…不得不服。最后还要记得给第一名的老鼠排名。

AC代码

#include <iostream>
#include<math.h>
#include<queue>
using namespace std;
struct Programmer {
	int weight, rank;
}p[1005];
int main()
{
	int total, ng, seq, groupNums, now;
	queue<int> que;
	scanf("%d%d", &total, &ng);
	for (int i = 0; i < total; i++) {
		scanf("%d", &p[i].weight);
	}
	for (int i = 0; i < total; i++) { //队列里为需要比较的老鼠序号
		scanf("%d", &seq);
		que.push(seq);
	}
    now = total;
	while (now > 1) { //这轮老鼠数
		groupNums = ceil((double)now / ng); //组数
		for (int i = 0; i < groupNums; i++) {
			int id = que.front();
			for (int j = 0; j < ng && i*ng + j < now; j++) {//每组找最大
				int seq = que.front();
				que.pop();
				if (p[seq].weight > p[id].weight) {//找出最大的id
					id = seq;
				}
				p[seq].rank = groupNums + 1;
			}
			que.push(id);
		}
		now = groupNums;
	}
	p[que.front()].rank = 1;
	for (int i = 0; i < total - 1; i++) { 
		printf("%d ", p[i].rank);
	}
	printf("%d\n", p[total - 1].rank);
	return 0;
}
发布了16 篇原创文章 · 获赞 0 · 访问量 354

猜你喜欢

转载自blog.csdn.net/qq_38507937/article/details/104332817