PAT甲级 1056 Mice and Rice (25 分)队列

1056 Mice and Rice (25 分)

Mice and Rice is the name of a programming contest in which each programmer must write a piece of code to control the movements of a mouse in a given map. The goal of each mouse is to eat as much rice as possible in order to become a FatMouse.

First the playing order is randomly decided for N​P​​ programmers. Then every N​G​​ programmers are grouped in a match. The fattest mouse in a group wins and enters the next turn. All the losers in this turn are ranked the same. Every N​G​​ winners are then grouped in the next match until a final winner is determined.

For the sake of simplicity, assume that the weight of each mouse is fixed once the programmer submits his/her code. Given the weights of all the mice and the initial playing order, you are supposed to output the ranks for the programmers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N​P​​ and N​G​​ (≤1000), the number of programmers and the maximum number of mice in a group, respectively. If there are less than N​G​​ mice at the end of the player's list, then all the mice left will be put into the last group. The second line contains N​P​​ distinct non-negative numbers W​i​​ (i=0,⋯,N​P​​−1) where each W​i​​ is the weight of the i-th mouse respectively. The third line gives the initial playing order which is a permutation of 0,⋯,N​P​​−1 (assume that the programmers are numbered from 0 to N​P​​−1). All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the final ranks in a line. The i-th number is the rank of the i-th programmer, and all the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:

11 3
25 18 0 46 37 3 19 22 57 56 10
6 0 8 7 10 5 9 1 4 2 3

Sample Output:

5 5 5 2 5 5 5 3 1 3 5

题目大意:np为老鼠的数量,ng为每组最多g个老鼠。先给出np个老鼠的重量,再给出老鼠的初始顺序(第i名的老鼠是第j号,j从0开始)。每ng个老鼠分为一组,对于每组老鼠,选出最重的那个,晋级下一轮比赛,然后依次再以np个老鼠一组分类,然后选出重量最大的。。。直到只剩下一只老鼠,排名为1.输出为老鼠的排名,这个排名是按照原输入老鼠的顺序输出的~

详情也可参考算法笔记上机训练实战指南7.2

#include<iostream>
#include<stdio.h>
#include<queue>
using namespace std;

struct node{
	int weight,rank;
};

int cmp(int a,int b){
	return a < b;
}

int main(){
	int np,ng;
	scanf("%d%d",&np,&ng);
	vector<node> mouse(np);
	for(int i=0;i<np;i++){
		scanf("%d",&mouse[i].weight);
	}
	
	queue<int> que;
	int index;
	for(int j=0;j<np;j++){
		scanf("%d",&index);
		que.push(index);
	}
	
	int count = np,group;
	while(!que.empty()){
		if(count % ng == 0)
			group = count / ng;
		else
			group = count / ng + 1;//不能整除组数要加一
			
		for(int i=0;i<group;i++){
			int maxid = que.front();//记录最大id 
			for(int j=0;j<ng;j++){
				if(i*ng + j == count)break;//最后一组老鼠可能不足ng 
				if(mouse[que.front()].weight > mouse[maxid].weight){
					maxid = que.front();
				}
				mouse[que.front()].rank = group + 1;//排名
				que.pop();//出队 
			}
			que.push(maxid);//每组最大的老鼠加入队列最后 
		}
		count = que.size();
		if(count == 1){//只剩余一个老鼠时排名为一 
			mouse[que.front()].rank = 1;
			break;
		}
	}
	
	for(int i=0;i<np;i++)
		printf("%s%d",i==0?"":" ",mouse[i].rank);
	
	return 0;
} 

猜你喜欢

转载自blog.csdn.net/qq_29762941/article/details/82717681