PAT 1056 Mice and Rice(模拟)

 Mice and Rice is the name of a programming contest in which each programmer must write a piece of code to control the movements of a mouse in a given map. The goal of each mouse is to eat as much rice as possible in order to become a FatMouse.

 First the playing order is randomly decided for N​P​​ programmers. Then every N​G​​ programmers are grouped in a match. The fattest mouse in a group wins and enters the next turn. All the losers in this turn are ranked the same. Every N​G​​ winners are then grouped in the next match until a final winner is determined.

 For the sake of simplicity, assume that the weight of each mouse is fixed once the programmer submits his/her code. Given the weights of all the mice and the initial playing order, you are supposed to output the ranks for the programmers.

Input Specification:

 Each input file contains one test case. For each case, the first line contains 2 positive integers: N​P​​ and N​G​​ (≤1000), the number of programmers and the maximum number of mice in a group, respectively. If there are less than N​G​​ mice at the end of the player's list, then all the mice left will be put into the last group. The second line contains N​P​​ distinct non-negative numbers W​i​​ (i=0,⋯,N​P​​−1) where each W​i​​ is the weight of the i-th mouse respectively. The third line gives the initial playing order which is a permutation of 0,⋯,N​P​​−1 (assume that the programmers are numbered from 0 to N​P​​−1). All the numbers in a line are separated by a space.

Output Specification:

 For each test case, print the final ranks in a line. The i-th number is the rank of the i-th programmer, and all the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:

11 3
25 18 0 46 37 3 19 22 57 56 10
6 0 8 7 10 5 9 1 4 2 3

Sample Output:

5 5 5 2 5 5 5 3 1 3 5

 题意:给你N只老鼠,每轮通过分组比较找出每组最肥的老鼠进入下一轮比较,直到找出最肥的那只老鼠,最后输出每只老鼠的排名 。每轮被淘汰的老鼠的排名等于该轮的分组数+1

代码

#include<iostream>
#include<cstdio>
#include<cstring>
#include<vector>
#include<algorithm>
using namespace std;
const int Max=1e3+5;
struct Node{
  int Wei;
  int ranks;
}mice[Max];
int main()
{
    int N,M,Now[Max],Next[Max];
    scanf("%d %d",&N,&M);
    for(int i=0;i<N;i++)
        scanf("%d",&mice[i].Wei);
    for(int i=0;i<N;i++)
        scanf("%d",&Now[i]);

    int Groups,sign,Count,Num;
    int MaxWei,Maxid;
    sign=0;
    Count=N;
    while(!sign)
    {
        Num=0;
        Groups=Count/M;
        if(Count%M!=0)
            Groups+=1;
        for(int i=0;i<Count;i+=M)
        {
            MaxWei=0;
            for(int v=i;v<i+M&&v<Count;v++)
            {
                int x=Now[v];
                if(mice[x].Wei>MaxWei)
                {
                    MaxWei=mice[x].Wei;
                    Maxid=x;
                }
            }
            for(int v=i;v<i+M&&v<Count;v++)
            {
                int x=Now[v];
                if(x!=Maxid)
                    mice[x].ranks=Groups+1;
            }
            Next[Num]=Maxid;
            Num+=1;
        }
        if(Count<=M)
        {
            mice[Maxid].ranks=1;
            break;
        }
        for(int i=0;i<Num;i++)
            Now[i]=Next[i];
        Count=Num;
    }
    for(int i=0;i<N;i++)
    {
        printf("%d",mice[i].ranks);
        if(i<N-1)
            printf(" ");
    }
    return 0;
}

 

猜你喜欢

转载自blog.csdn.net/ZCMU_2024/article/details/84993632