PAT.A1056 Mice and Rice

Mice and Rice is the name of a programming contest in which each programmer must write a piece of code to control the movements of a mouse in a given map. The goal of each mouse is to eat as much rice as possible in order to become a FatMouse.

First the playing order is randomly decided for N~P~ programmers. Then every N~G~ programmers are grouped in a match. The fattest mouse in a group wins and enters the next turn. All the losers in this turn are ranked the same. Every N~G~ winners are then grouped in the next match until a final winner is determined.

For the sake of simplicity, assume that the weight of each mouse is fixed once the programmer submits his/her code. Given the weights of all the mice and the initial playing order, you are supposed to output the ranks for the programmers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N~P~ and N~G~ (<= 1000), the number of programmers and the maximum number of mice in a group, respectively. If there are less than N~G~ mice at the end of the player's list, then all the mice left will be put into the last group. The second line contains N~P~ distinct non-negative numbers W~i~ (i=0,...N~P~-1) where each W~i~ is the weight of the i-th mouse respectively. The third line gives the initial playing order which is a permutation of 0,...N~P~-1 (assume that the programmers are numbered from 0 to N~P~-1). All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the final ranks in a line. The i-th number is the rank of the i-th programmer, and all the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:

11 3
25 18 0 46 37 3 19 22 57 56 10
6 0 8 7 10 5 9 1 4 2 3

Sample Output:

5 5 5 2 5 5 5 3 1 3 5
#include<cstdio>
#include<cstring>
#include<vector>
#include<algorithm>
#include<iostream>
#include<string>
#include<set>
#include<map>
#include<utility>
#include<stack>
#include<queue>
using namespace std;
const int maxn = 1010;
struct mouse {
	int weight;
	int rank;
}mouse[maxn];
int main() {
	int np, ng,r;
	scanf("%d%d", &np, &ng);
	queue<int> q1, q2;
for (int i = 0; i < np; i++) {
		int t;
		scanf("%d", &t);
		mouse[i].weight = t;
	}
	for (int i = 0; i < np; i++) {
		int t;
		scanf("%d", &t);
		q1.push(t);
	}
	while (1) {
		int max = -1, k = -1, i = 1, s = q1.size();
		if (q1.size() % ng == 0) r = q1.size() / ng + 1;
		else r = q1.size() / ng + 2;
		while (!q1.empty()) {
			if (mouse[q1.front()].weight > max) {
				max = mouse[q1.front()].weight;
				k = q1.front();
			}
			mouse[q1.front()].rank = r;
			q1.pop();
			if (i% ng == 0 || i == s) {
				q2.push(k);
				max = -1;
				k = -1;
			}
			i++;
		}
		while (!q2.empty()) {
			q1.push(q2.front());
			q2.pop();
		}
		if (q1.size() == 1) {
			mouse[q1.front()].rank = 1;
			break;
		}
	}
	for (int i = 0; i < np; i++) {
		printf("%d", mouse[i].rank);
		if (i < np - 1) printf(" ");
	}

	return 0;
}

猜你喜欢

转载自blog.csdn.net/mokena1/article/details/81037454