#1056. Mice and Rice【模拟】

原题链接

Problem Description:

Mice and Rice is the name of a programming contest in which each programmer must write a piece of code to control the movements of a mouse in a given map. The goal of each mouse is to eat as much rice as possible in order to become a FatMouse.

First the playing order is randomly decided for N P N_P NP programmers. Then every N G N_G NG programmers are grouped in a match. The fattest mouse in a group wins and enters the next turn. All the losers in this turn are ranked the same. Every N G N_G NG winners are then grouped in the next match until a final winner is determined.

For the sake of simplicity, assume that the weight of each mouse is fixed once the programmer submits his/her code. Given the weights of all the mice and the initial playing order, you are supposed to output the ranks for the programmers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N P N_P NP and N G N_G NG ( ≤ 1000 \leq 1000 1000), the number of programmers and the maximum number of mice in a group, respectively. If there are less than N G N_G NG mice at the end of the player’s list, then all the mice left will be put into the last group. The second line contains N P N_P NP distinct non-negative numbers W i W_i Wi ( i = 0 , ⋯   , N P − 1 i=0,\cdots,N_{P−1} i=0,,NP1) where each W i W_i Wi is the weight of the i i i-th mouse respectively. The third line gives the initial playing order which is a permutation of 0 , ⋯   , N P − 1 0,\cdots, N_{P−1} 0,,NP1 (assume that the programmers are numbered from 0 to N P − 1 N_{P−1} NP1). All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the final ranks in a line. The i i i-th number is the rank of the i i i-th programmer, and all the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:

11 3
25 18 0 46 37 3 19 22 57 56 10
6 0 8 7 10 5 9 1 4 2 3

Sample Output:

5 5 5 2 5 5 5 3 1 3 5

Problem Analysis:

模拟题,详细见代码注释。

Code

#include <iostream>
#include <cstring>
#include <algorithm>

using namespace std;

const int N = 1e3 + 10;

int n, m;
int w[N], rk[N];

int main()
{
    
    
    cin >> n >> m; // 每 m 个老鼠一组,最后一组可能不足 m个
    for (int i = 0; i < n; i ++ ) cin >> w[i];
    vector<int> cur(n); // 存储当前所有组的老鼠
    
    for (int i = 0; i < n; i ++ ) cin >> cur[i];
    
    while (cur.size() > 1)
    {
    
    
        vector<int> next; // 存储下一组的老鼠
        int remain = (cur.size() + m - 1) / m; // 选出来的老鼠数量
        
        for (int i = 0; i < cur.size();) // 枚举每组的起点
        {
    
    
            // 起点是i, 终点是 i + m 和 n取min
            int j = min((int)cur.size(), i + m); // [i, j - 1)
            
            /* eg:
	            123 456 789 123 45
	            m = 3
	            组数 = 5, 
	            剩下的:12 45 78 12 4 
	            => 124 578 124
			*/
            
            // 找到当前这组最重的老鼠编号
            int t = i; 
            for (int k = i; k < j; k ++ )
                if (w[cur[k]] > w[cur[t]])
                    t = k;
            next.push_back(cur[t]);
            for (int k = i; k < j; k ++ )
                if (k != t)
                    rk[cur[k]] = remain + 1;
            i = j; 
        }
        cur = next;
    }
    
    rk[cur[0]] = 1; // 特判最后冠军老鼠
    for (int i = 0; i < n; i ++ )
    {
    
    
        cout << rk[i];
        if (i != n - 1) cout << ' ';
    }
    cout << endl;
    return 0;
}

猜你喜欢

转载自blog.csdn.net/geraltofrivia123/article/details/121135676
今日推荐