1056 Mice and Rice (25point(s))

1056 Mice and Rice (25point(s))

Mice and Rice is the name of a programming contest in which each programmer must write a piece of code to control the movements of a mouse in a given map. The goal of each mouse is to eat as much rice as possible in order to become a FatMouse.

First the playing order is randomly decided for N
​P
​​ programmers. Then every N
​G
​​ programmers are grouped in a match. The fattest mouse in a group wins and enters the next turn. All the losers in this turn are ranked the same. Every N
​G
​​ winners are then grouped in the next match until a final winner is determined.

For the sake of simplicity, assume that the weight of each mouse is fixed once the programmer submits his/her code. Given the weights of all the mice and the initial playing order, you are supposed to output the ranks for the programmers.

Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive integers: N
​P
​​ and N
​G
​​ (≤1000), the number of programmers and the maximum number of mice in a group, respectively. If there are less than N
​G
​​ mice at the end of the player’s list, then all the mice left will be put into the last group. The second line contains N
​P
​​ distinct non-negative numbers W
​i
​​ (i=0,⋯,N
​P
​​ −1) where each W
​i
​​ is the weight of the i-th mouse respectively. The third line gives the initial playing order which is a permutation of 0,⋯,N
​P
​​ −1 (assume that the programmers are numbered from 0 to N
​P
​​ −1). All the numbers in a line are separated by a space.

Output Specification:
For each test case, print the final ranks in a line. The i-th number is the rank of the i-th programmer, and all the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:
11 3
25 18 0 46 37 3 19 22 57 56 10
6 0 8 7 10 5 9 1 4 2 3
Sample Output:
5 5 5 2 5 5 5 3 1 3 5

计算出每次比较的老鼠数量 和 组数。
排名为组数+1

#include<bits/stdc++.h>
using namespace std;
int weight[1010],ranking[1010];
int main(){
    
    
    int np,ng;
    scanf("%d%d",&np,&ng);
    for(int i=0;i<np;++i)
        scanf("%d",&weight[i]);
    queue<int> q;
    int sequence;
    for(int i=0;i<np;++i){
    
    
        cin>>sequence;
        q.push(sequence);
    }
    int group,temp=np;
    while(temp!=1){
    
    
        group=temp%ng==0?temp/ng:(temp/ng+1);
        for(int i=0;i<group;++i){
    
    
            int maxP=q.front();
            for(int j=0;j<ng;++j){
    
    
                if(i*ng+j>=temp) break;
                int k=q.front();
                if(weight[maxP]<weight[k])
                    maxP=k;
                ranking[k]=group+1;
                q.pop();
            }
            q.push(maxP);
        }
        temp=group;
    }
    ranking[q.front()]=1;//莫忘
    for(int i=0;i<np;++i){
    
    
        if(i!=0) cout<<" ";
        cout<<ranking[i];
    }
    cout<<endl;
}

猜你喜欢

转载自blog.csdn.net/weixin_44970602/article/details/111873325