(难+ 要再看)A1056 Mice and Rice (25 分)

Mice and Rice is the name of a programming contest in which each programmer must write a piece of code to control the movements of a mouse in a given map. The goal of each mouse is to eat as much rice as possible in order to become a FatMouse.

First the playing order is randomly decided for N​P​​ programmers. Then every N​G​​ programmers are grouped in a match. The fattest mouse in a group wins and enters the next turn. All the losers in this turn are ranked the same. Every N​G​​ winners are then grouped in the next match until a final winner is determined.

For the sake of simplicity, assume that the weight of each mouse is fixed once the programmer submits his/her code. Given the weights of all the mice and the initial playing order, you are supposed to output the ranks for the programmers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N​P​​ and N​G​​ (≤1000), the number of programmers and the maximum number of mice in a group, respectively. If there are less than N​G​​ mice at the end of the player's list, then all the mice left will be put into the last group. The second line contains N​P​​ distinct non-negative numbers W​i​​ (i=0,⋯,N​P​​−1) where each W​i​​ is the weight of the i-th mouse respectively. The third line gives the initial playing order which is a permutation of 0,⋯,N​P​​−1 (assume that the programmers are numbered from 0 to N​P​​−1). All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the final ranks in a line. The i-th number is the rank of the i-th programmer, and all the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:

11 3
25 18 0 46 37 3 19 22 57 56 10
6 0 8 7 10 5 9 1 4 2 3

Sample Output:

5 5 5 2 5 5 5 3 1 3 5

题意:

给定 NP  只老鼠的质量 ,并给出他们的初始序列,按照这个初始序列把这些老鼠按每 NG 只分为一组,最后不够 NG 只的也单独分为一组。对每组老鼠,选出他们中质量最大的一只晋级,这样晋级的;老鼠就等于该轮分组的组数,对这些晋级的老鼠再按照上面的步骤每 NG 只分为一组进行比较,选出质量最大的一批继续晋级,这样直到最后只剩下 1 只老鼠,排名为 1。把这些老鼠的排名按照原输入的顺序输出。

输入:第一行给出 NP 和 NG (≤1000),第二行按序给出每只老鼠的质量,第三行给出初始序列(即 6 号老鼠排在第一位,0 号老鼠排在第二位:也就是 19 在 第一个,25 在第二个)

样例分析:

有输入可以得到,初始时老鼠的顺序为:

第一次 19 25 57 22 10 3 56 18 37 0 46

第二次           57         56              46

第三次           57                           46

第四次           57

知识点:

queue

  1. 添加 #include <queue>; using namespace std;
  2. 定义:queue<typename> name;
  3. 队列只能通过 front() 和 back() 来访问首尾元素
  4. 其他用法基本与 stack 相同

运行超时

#include <cstdio>
#include <queue>
using namespace std;
const int maxn = 1010;
struct mouse{
    int weight;
    int R;
}mouse[maxn];
int main(){
    int nq, ng, order;
    scanf("%d%d", &nq, &ng);
    for(int i = 0; i < nq; i++){
        scanf("%d", &mouse[i].weight);
    }
    queue<int> q;
    for(int i = 0; i < nq; i++){
        scanf("%d", &order);
        q.push(order);      //按顺序把老鼠们的标号入队
    }
    int temp = nq, group;   //temp为当前轮的比赛总老鼠数,group为组数
    while(q.size() != 1){
        //计算group,即当前轮分为几组进行比较
        if(temp % nq == 0)
            group = temp / nq;
        else
            group = temp / nq + 1;
        //枚举每一组,选出该组老鼠中质量最大的
        for(int i = 0; i < group; i++){
            int k = q.front();      //k 存放该组质量最大的老鼠编号
            for(int j = 0; j < ng; j++){
                if(i * ng + j >= temp)
                    break;
                int front = q.front();
                if(mouse[front].weight > mouse[k].weight){
                    k = front;
                }
                mouse[front].R = group + 1;
                q.pop();
            }
            q.push(k);
        }
        temp = group;
    }
    mouse[q.front()].R = 1;
    for(int i = 0; i < nq; i++){
        printf("%d", mouse[i].R);
        if(i < nq - 1)
            printf(" ");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_35093872/article/details/87857252