1056 Mice and Rice (25 分)分组求最大值

版权声明:假装这里有个版权声明…… https://blog.csdn.net/CV_Jason/article/details/85238006

题目

Mice and Rice is the name of a programming contest in which each programmer must write a piece of code to control the movements of a mouse in a given map. The goal of each mouse is to eat as much rice as possible in order to become a FatMouse.

First the playing order is randomly decided for N P N_P programmers. Then every N G N_G programmers are grouped in a match. The fattest mouse in a group wins and enters the next turn. All the losers in this turn are ranked the same. Every N G N_G winners are then grouped in the next match until a final winner is determined.

For the sake of simplicity, assume that the weight of each mouse is fixed once the programmer submits his/her code. Given the weights of all the mice and the initial playing order, you are supposed to output the ranks for the programmers.

Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive integers: N P N_P and N G ( 1000 ) N_G(≤1000) , the number of programmers and the maximum number of mice in a group, respectively. If there are less than N G N_G mice at the end of the player’s list, then all the mice left will be put into the last group. The second line contains N P N_P distinct non-negative numbers W i ( i = 0 , , N P 1 ) W_​i(i=0,⋯,N_P-1) where each W i W_i is the weight of the i-th mouse respectively. The third line gives the initial playing order which is a permutation of 0 , , N P 1 0,⋯,N_P-1 (assume that the programmers are numbered from 0 to N P 1 N_P-1 ). All the numbers in a line are separated by a space.

Output Specification:
For each test case, print the final ranks in a line. The i-th number is the rank of the i-th programmer, and all the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:

11 3
25 18 0 46 37 3 19 22 57 56 10
6 0 8 7 10 5 9 1 4 2 3

Sample Output:

5 5 5 2 5 5 5 3 1 3 5

解题思路

  题目大意: 给你 N P N_P 个老鼠以及他们的重量 W W ,每 N G N_G 个老鼠分一个组,不够 N G N_G 个数的单独算一个组,比他们每个组的最大值,最大值进入下一轮的比较,同组其余老鼠皆为淘汰,并与其他组同时被淘汰的老鼠排名一致,求所有老鼠的排名。
  解题思路: 这道题的难点在于对数据进行分组,比较并进行排名,其中,老鼠的排名等于该轮比赛分组个数+1——本轮比较分group个组,意味着有group个优胜者,也就是说,其余所有被淘汰的都在这group之后,即group+1.所以我们直接每轮的分组数即可。大题过程,如图所示——

  在这里插入图片描述

#include <iostream>
#include <vector>
using namespace std;

int main(){
	int n, m, x;
	cin >> n >> m;
	vector<int> mice(n);
	vector<int> order(n);
	int rank[n];
	fill(rank,rank+n,0);
	
	for (int i = 0; i < n; ++i) {
		cin>>mice[i];
	}
	for (int i = 0; i < n; ++i) {
		cin>>order[i];
	}
	vector<int> res;
	int Max, idex, group;
	while (order.size()>1) {
		group = order.size() / m + 1;
		if ((order.size() % m != 0) ) ++group;
		for (int i = 0; i < order.size(); ++i) {
			if (i%m == 0) {
				Max = -1;
				if (i != 0) {
					res.push_back(idex);
				}
			}
			if (Max < mice[order[i]]) {
				Max = mice[order[i]];
				idex = order[i];
			}
			rank[order[i]] = group;
		}
		res.push_back(idex);
		order = res;
		res.clear();
	}
	rank[order[0]] = 1;
	for (int i = 0; i < n; ++i) {
		if (i != 0) cout << ' ';
		cout << rank[i];
	}
	return 0;
}

在这里插入图片描述

总结

  这道题看起来不难,但是做起来挺难的,我做了好久……如果是在考场上,我可能拿不到分……甚是惭愧。

猜你喜欢

转载自blog.csdn.net/CV_Jason/article/details/85238006