PAT A1056 Mice and Rice+队列初探

Mice and Rice is the name of a programming contest in which each programmer must write a piece of code to control the movements of a mouse in a given map. The goal of each mouse is to eat as much rice as possible in order to become a FatMouse.

First the playing order is randomly decided for N​P​​ programmers. Then every N​G​​ programmers are grouped in a match. The fattest mouse in a group wins and enters the next turn. All the losers in this turn are ranked the same. Every N​G​​ winners are then grouped in the next match until a final winner is determined.

For the sake of simplicity, assume that the weight of each mouse is fixed once the programmer submits his/her code. Given the weights of all the mice and the initial playing order, you are supposed to output the ranks for the programmers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N​P​​ and N​G​​ (≤1000), the number of programmers and the maximum number of mice in a group, respectively. If there are less than N​G​​ mice at the end of the player's list, then all the mice left will be put into the last group. The second line contains N​P​​ distinct non-negative numbers W​i​​ (i=0,⋯,N​P​​−1) where each W​i​​ is the weight of the i-th mouse respectively. The third line gives the initial playing order which is a permutation of 0,⋯,N​P​​−1(assume that the programmers are numbered from 0 to N​P​​−1). All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the final ranks in a line. The i-th number is the rank of the i-th programmer, and all the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:

11 3
25 18 0 46 37 3 19 22 57 56 10
6 0 8 7 10 5 9 1 4 2 3

Sample Output:

5 5 5 2 5 5 5 3 1 3 5

代码:

#include <iostream>
#include <queue>

using namespace std;

const int maxn=1010;

struct mouse{
    int weight;
    int R;
}mouse[maxn];


int main()
{
    int p,g,order;
    cin >> p >> g;
    for(int i=0;i<p;i++)
        scanf("%d",&mouse[i].weight);
    queue<int> q;
    for(int i=0;i<p;i++){
        scanf("%d",&order);
        q.push(order);
    }
    int maxi=-1,group;
    while(q.size()>1){ //>1说明是倒数第二轮,这轮操作后,队列只剩一个最大元素
        int num=q.size();
        if(num%g==0)
            group=num/g;
        else
            group=num/g+1;   //group表示该轮分组数
        for(int i=1;i<=num;i++){
            mouse[q.front()].R=group+1; //让每一个出队的都是最大RANK
            if(maxi==-1)             //maxi==-1表示这个元素是这组第一个
                maxi=q.front();
            if(mouse[q.front()].weight>mouse[maxi].weight)  //这组里有更大weight的记录小标
                maxi=q.front();
            q.pop();
            if(i%g==0 || i==num){    //每g个或是最后一个元素表示一组结束
                q.push(maxi);        //把maxi入队
                maxi=-1;
            }
        }
    }
    mouse[q.front()].R=1;         //此时队列里还有一个最大元素的小标,让其Rank=1
    for(int i=0;i<p;i++){         //控制输出
        cout << mouse[i].R;
        if(i!=p-1)
            cout << " ";
    }
}

猜你喜欢

转载自blog.csdn.net/qq_36525099/article/details/88383700
今日推荐