Ignatius and the Princess IV

"OK, you are not too bad, em... But you can never pass the next test." feng5166 says. 

"I will tell you an odd number N, and then N integers. There will be a special integer among them, you have to tell me which integer is the special one after I tell you all the integers." feng5166 says. 

"But what is the characteristic of the special integer?" Ignatius asks. 

"The integer will appear at least (N+1)/2 times. If you can't find the right integer, I will kill the Princess, and you will be my dinner, too. Hahahaha....." feng5166 says. 

Can you find the special integer for Ignatius? 

Input

The input contains several test cases. Each test case contains two lines. The first line consists of an odd integer N(1<=N<=999999) which indicate the number of the integers feng5166 will tell our hero. The second line contains the N integers. The input is terminated by the end of file. 

Output

For each test case, you have to output only one line which contains the special number you have found. 

Sample Input

5
1 3 2 3 3
11
1 1 1 1 1 5 5 5 5 5 5
7
1 1 1 1 1 1 1

Sample Output

3
5
1

题解:

给一个奇数N。然后是N个整数。在它们之间会有一个特殊的整数,这个整数至少会出现(N+1)/2次,找出它。


代码

#include<iostream>
#include<string.h>
#include<stdio.h>
#include<algorithm>
using namespace std;
int num[1000001];//存放输入的数字的个数
int main()
{
	int n,m,i,t;
	while(scanf("%d",&n)!=EOF)
	{
		memset(num,0,sizeof(num));
		for(i=0;i<n;i++)
	    {
	    	scanf("%d",&m);
	    	num[m]++;
	    	if(num[m]==(n+1)/2)
	    	   t=m; 
		}
		printf("%d\n",t);
	}
	return 0;
}
注:
不能用cin,cout会超时

猜你喜欢

转载自blog.csdn.net/lshsgbb2333/article/details/79931555