【PAT】1028. List Sorting (25)

题目


链接:https://www.patest.cn/contests/pat-a-practise/1028

Excel can sort records according to any column. Now you are supposed to imitate this function.

Input

Each input file contains one test case. For each case, the first line contains two integers N (<=100000) and C, where N is the number of records and C is the column that you are supposed to sort the records with. Then N lines follow, each contains a record of a student. A student’s record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).

Output

For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID’s; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID’s in increasing order.

Sample Input 1
3 1
000007 James 85
000010 Amy 90
000001 Zoe 60
Sample Output 1
000001 Zoe 60
000007 James 85
000010 Amy 90
Sample Input 2
4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98
Sample Output 2
000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60
Sample Input 3
4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 90
Sample Output 3
000001 Zoe 60
000007 James 85
000002 James 90
000010 Amy 90




分析


题意:

1. C == 1
根据学号排序(升序)
2. C == 2
根据名字(升序)
3. C == 3
根据分数(升序)

若有相同,则根据学号升序</font>




题解(已AC)


/**
    2018.2.2
    Donald
*/
//1028. List Sorting (25)

/**
    1. C == 1
        根据学号排序(升序)
    2. C == 2
        根据名字(升序)
    3. C == 3
        根据分数(升序)

    若有相同,则根据学号升序
*/


#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define MAXN 100005

struct Student {
    int id;
    char name[9];
    int score;
};

int N;
int C;
Student stu[MAXN];

bool compare1(Student a, Student b) {
    return a.id < b.id;
}

bool compare2(Student a, Student b) {
    return strcmp(a.name, b.name) != 0 ? strcmp(a.name, b.name) < 0 : a.id < b.id;
}

bool compare3(Student a, Student b) {
    return a.score != b.score ? a.score < b.score : a.id < b.id;
}

int main(void) {

    while (scanf("%d %d", &N, &C) == 2) {
        for (int i = 0; i < N; ++i) {
            scanf("%d %s %d", &stu[i].id, stu[i].name, &stu[i].score);
        }

        if (C == 1) {
            sort(stu, stu + N, compare1);
        } else if (C == 2) {
            sort(stu, stu + N, compare2);
        } else if (C == 3) {
            sort(stu, stu + N, compare3);
        }
        for (int i = 0; i < N; ++i) {
            printf("%06d %s %d\n", stu[i].id, stu[i].name, stu[i].score);
        }
    }


    return 0;
}

猜你喜欢

转载自blog.csdn.net/fanfan4569/article/details/79241583