Period POJ - 1961

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A K ,that is A concatenated K times, for some string A. Of course, we also want to know the period K.
Input
The input consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S.The second line contains the string S. The input file ends with a line, having the
number zero on it.
Output
For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.
Sample Input
3
aaa
12
aabaabaabaab
0
Sample Output
Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4
这个题用kmp算法做,主要利用next数组
用next数组可以求出公共子缀的最大长度
i - next[i]就是一个循环节的大小
而i / (i - next[i])就是循环节的个数
所以可以得出如下代码

#include <stdio.h>
#include <stdlib.h>
void fail(char* p,int *next,int m);
int main()
{
    int *list = (int *)malloc(sizeof(int) * 1e6);
    char *str = (char*)malloc(sizeof(char) * 1e6);
    int n;int counter = 1;
    scanf("%d",&n);
    while(n)
    {
        
          
        printf("Test case #%d\n",counter++);
        scanf("%s",str);

        fail(str,list,n);
        for(int i = 1;i < n + 1;i++)
        {
            int j = i - list[i];
            if(i % j == 0 && i / j > 1)
                printf("%d %d\n",i,i / j);
        }
        printf("\n");
        scanf("%d",&n);
    }
    free(str);free(list);

}
void fail(char* p,int *next,int m)
{
    int i = 0,j = -1;
    next[0] = j;
    while(i < m)
    {
        if(j == -1 || p[i] == p[j])
        {
            i++;j++;
            next[i] = j;
        }
        else
            j = next[j];
    }
}
发布了39 篇原创文章 · 获赞 4 · 访问量 5752

猜你喜欢

转载自blog.csdn.net/weixin_45725137/article/details/105282092