POJ 1961 Period【KMP--next数组】

版权声明:转载什么的好说,附上友链就ojek了,同为咸鱼,一起学习。 https://blog.csdn.net/sodacoco/article/details/88029268

题目:

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A K , that is A concatenated K times, for some string A. Of course, we also want to know the period K. 

Input

The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it. 

Output

For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case. 

Sample Input

3
aaa
12
aabaabaabaab
0

Sample Output

Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4

题目大意: 

       给定一个字符串,求 所有的 由循环节组成的前缀 的 长度 以及 其中循环节的最大数目 ;

解题思路:

       遍历所有的前缀,用Next数组得到前缀的最小循环节,判断前缀是否由循环节组成,输出结果。

实现代码:

#include<cstdio>
#include<string>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
const int MM=1000005;

int ne[MM];
char mo[MM];
int lm;
void Get_next(){
    int i=0,j=-1;
    ne[0]=-1;
    while(i<lm){
        while(j!=-1&&mo[i]!=mo[j])
            j=ne[j];
        ne[++i]=++j;
    }
}
int main(){
    int n,cas=1;
    while(scanf("%d",&n)&&n!=0){
        scanf("%s",mo);
        int k=0;
        lm=strlen(mo);
        memset(ne,0,sizeof(ne));
        Get_next();
        printf("Test case #%d\n",cas++);
        for(int i=2;i<=lm;i++){
            int k=i-ne[i];
            if(i/k>1&&i%k==0)printf("%d %d\n",i,(i/k));
        }printf("\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/sodacoco/article/details/88029268