poj 1961 Period (KMP+最小循环节)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/sdz20172133/article/details/84455132

Period

Time Limit: 3000MS   Memory Limit: 30000K
Total Submissions: 20563   Accepted: 10022

Description

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as AK ,that is A concatenated K times, for some string A. Of course, we also want to know the period K.

Input

The input consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S.The second line contains the string S. The input file ends with a line, having the 
number zero on it.

Output

For each test case, output "Test case #" and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.

Sample Input

3
aaa
12
aabaabaabaab
0

Sample Output

Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4

Source

Southeastern Europe 2004

扫描二维码关注公众号,回复: 4227167 查看本文章

算法分析:

题意:

给定一个长度为n的字符串s,求它的每个前缀的最短循环节。换句话说,对于每个i(2<=i<=n),求一个最大的整数K>1(如果K存在),使得S的前i个字符组成的前缀是某个字符串重复K次得到的。输出所有存在K的i和对应的K。

比如对于字符串aabaabaabaab, 只有当i=2,6,9,12时K存在,且分别为2,2,3,4

分析:

这里就需要我们知道next数组的含义:next[i]=k表示s[1...i-1]最大前缀与后缀匹配数(相当于最大前缀的末位置),如果next[i]>0则i-next[i]为字符串匹配的时候移动的位数,

画出图如下

我们发现,如果1后面和4前面的字符串能够均分,且长度相同,这四段字符串两两相等。所以,满足i%(i-next[i])==0,即可。

所以可以推出一个重要的性质len-next[i]为此字符串s[1...i]的最小循环节(i为字符串的结尾),另外如果len%(len-next[i])==0,此字符串的最小周期就为len/(len-next[i]);

#include<cstdio>
#include<iostream>
#include<fstream>
#include<algorithm>
#include<functional>
#include<cstring>
#include<string>
#include<cstdlib>
#include<iomanip>
#include<numeric>
#include<cctype>
#include<cmath>
#include<ctime>
#include<queue>
#include<stack>
#include<list>
#include<set>
#include<map>
using namespace std;
 
const int N = 1000002;
int nxt[N];
char  T[N];
int  tlen;
 
void getNext()
{
    int j, k;
    j = 0; k = -1;
	nxt[0] = -1;
    while(j < tlen)
        if(k == -1 || T[j] == T[k])
           {
           	nxt[++j] = ++k;
           	if (T[j] != T[k]) //优化
				nxt[j] = k; 
           } 
        else
            k = nxt[k];
 
}


int main()
{
 
    int TT;
	
	int kase=1;
    while(scanf("%d",&tlen)!=-1)
    {
    	if(tlen==0) break;
        scanf("%s",&T);
        printf("Test case #%d\n",kase++);
		getNext();
       for(int i=2;i<=tlen;i++)
	   {
	   
	   	if(nxt[i]>0&&(i)%(i-nxt[i])==0)
       	printf("%d %d\n",i,i/(i-nxt[i]));
	   }
	   cout<<endl;
       	 
    }
    return 0;
}
 

猜你喜欢

转载自blog.csdn.net/sdz20172133/article/details/84455132