PAT A1022 Digital Library (30分)

题目链接https://pintia.cn/problem-sets/994805342720868352/problems/994805480801550336

题目描述
A Digital Library contains millions of books, stored according to their titles, authors, key words of their abstracts, publishers, and published years. Each book is assigned an unique 7-digit number as its ID. Given any query from a reader, you are supposed to output the resulting books, sorted in increasing order of their ID’s.

输入
Each input file contains one test case. For each case, the first line contains a positive integer N (≤10
​4
​​ ) which is the total number of books. Then N blocks follow, each contains the information of a book in 6 lines:

Line #1: the 7-digit ID number;
Line #2: the book title – a string of no more than 80 characters;
Line #3: the author – a string of no more than 80 characters;
Line #4: the key words – each word is a string of no more than 10 characters without any white space, and the keywords are separated by exactly one space;
Line #5: the publisher – a string of no more than 80 characters;
Line #6: the published year – a 4-digit number which is in the range [1000, 3000].

It is assumed that each book belongs to one author only, and contains no more than 5 key words; there are no more than 1000 distinct key words in total; and there are no more than 1000 distinct publishers.

After the book information, there is a line containing a positive integer M (≤1000) which is the number of user’s search queries. Then M lines follow, each in one of the formats shown below:
1: a book title
2: name of an author
3: a key word
4: name of a publisher
5: a 4-digit number representing the year

输出
For each query, first print the original query in a line, then output the resulting book ID’s in increasing order, each occupying a line. If no book is found, print Not Found instead.

样例输入
3
1111111
The Testing Book
Yue Chen
test code debug sort keywords
ZUCS Print
2011
3333333
Another Testing Book
Yue Chen
test code sort keywords
ZUCS Print2
2012
2222222
The Testing Book
CYLL
keywords debug book
ZUCS Print2
2011
6
1: The Testing Book
2: Yue Chen
3: keywords
4: ZUCS Print
5: 2011
3: blablabla

样例输出
1: The Testing Book
1111111
2222222
2: Yue Chen
1111111
3333333
3: keywords
1111111
2222222
3333333
4: ZUCS Print
1111111
5: 2011
1111111
2222222
3: blablabla
Not Found

代码

#include <iostream>
#include <string>
#include <map>
#include <set>
using namespace std;

int main() {
    int n,m,id,num;
    string title, author, key, pub, year;
    map<string, set<int> > mp[6];	// 1:书名  2:作者姓名  3:一个关键词  4:发布者名称  5:代表年份的4位数字
    scanf("%d",&n);  
    for(int i = 0; i < n; i++){
        scanf("%d",&id);
        getchar();			
        getline(cin, title); mp[1][title].insert(id);
        getline(cin,author); mp[2][author].insert(id);
        while(cin >> key){
           mp[3][key].insert(id);
           if(getchar()=='\n') break;		//有多个关键字!
        }
        getline(cin, pub); mp[4][pub].insert(id);
        getline(cin, year); mp[5][year].insert(id);
	}  
    scanf("%d", &m);
    while(m--){
        scanf("%d: ",&num);
        string str;
        getline(cin, str);
        cout << num << ": " << str << "\n";
 		if(mp[num].find(str) != mp[num].end())
        	for(set<int>::iterator it = mp[num][str].begin(); it != mp[num][str].end(); it++)
            	printf("%07d\n", *it);
    	else printf("Not Found\n");
    }
    return 0;
}
发布了364 篇原创文章 · 获赞 13 · 访问量 2万+

猜你喜欢

转载自blog.csdn.net/Rhao999/article/details/105292820