【HDU1114】Piggy-Bank(完全背包)

**

Piggy-Bank

**

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 20204 Accepted Submission(s): 10266

Problem Description

Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid.

But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs!

Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it’s weight in grams.

Output
Print exactly one line of output for each test case. The line must contain the sentence “The minimum amount of money in the piggy-bank is X.” where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line “This is impossible.”.

Sample Input
3
10 110
2
1 1
30 50
10 110
2
1 1
50 30
1 6
2
10 3
20 4

Sample Output
The minimum amount of money in the piggy-bank is 60.
The minimum amount of money in the piggy-bank is 100.
This is impossible.

Source
Central Europe 1999

题目大意:你有一个存钱罐,叫你输入存钱罐空的时候有多重和存满钱的时候有多重。然后输入一个数字n分别代表n种背包,输入其价值以及重量。

解析:01背包是每种东西只有一个,完全背包是每种东西不限数量
既然01背包逆序的原因是为了是max中的两项是前一状态值
所以当我们把i从1到N循环时,f[v]表示容量为v在前i种背包时所得的价值,这里我们要添加的不是前一个背包,而是当前背包。只要顺序来min两项的状态就行了。

#include "iostream"
#include "cstdio"
#include "cstring"
#include "algorithm"

using namespace std;

const int maxn = 1e4+5;
const int maxnn = 1e3;
const int INF = 999999;

int w[maxnn],v[maxnn];
int dp[maxn];
int T;
int emp,ful,size;
int n;
int min(int a,int b){
    return a<b?a:b;
}

int main(){

    scanf("%d",&T);
    while(T--){
        memset(dp,INF,sizeof(dp));
        dp[0]=0;
        scanf("%d%d",&emp,&ful);
        size = ful-emp;
        scanf("%d",&n);
        for(int i=0 ; i<n ; i++){
            scanf("%d%d",&v[i],&w[i]);
        }
        for( int i=0 ; i<n ; i++ ){
            for( int j=w[i] ; j<=size ; j++ ){
                dp[j]=min(dp[j],dp[j-w[i]]+v[i]);
            }
        }
        if(dp[size]<999999)
        cout<<"The minimum amount of money in the piggy-bank is "<<dp[size]<<"."<<endl;
        else
        cout<<"This is impossible."<<endl;
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/thesprit/article/details/51944978
今日推荐