hdu1114 Piggy-Bank (简单完全背包)

Problem Description

     Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid.

    But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs!

Input

The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams.

 

Output

Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line "This is impossible."

Sample Input

3

10 110

2

1 1

30 50

10 110

2

1 1

50 30

1 6

2

10 3

20 4

Sample Output

The minimum amount of money in the piggy-bank is 60.

The minimum amount of money in the piggy-bank is 100.

This is impossible.

题目大意

    给出空存钱罐与装钱后的质量,以及存钱罐放的硬币的质量及价值,求用给出的钱能不能正好达到存钱罐中放的钱的质量,若能则输出满足要求的最小的总价值,不能则输出This is impossible.

思路 

   因为给出的每种面值的硬币可以多次使用,符合完全背包问题。

   状态转移方程  dp[ j ]=min ( dp[ j ] , dp [ j - weight [ i ] ] + price [ i ] ).

完全背包要点:

  for i=1..N

    for v=0..V

        f[v]=max{f[v],f[v-c[i]]+w[i]}

  顺序!

  因为每种物品都是无限,当我们将i从1循环到n时,f[v]表示容量为v在前i种物品时所得的价值,这里我们要添加的不是前一个物品,而是当前物品,所以我们要考虑的是当前状态。

 AC代码

​
#include<stdio.h>

#include<iostream>
#include<algorithm>
#include<string.h>
using namespace std;
int price[501],weight[501],record[10001];
#define INF 9999999
int main()
{
    int t;
    scanf("%d",&t);
    int e,f,n,v;     // f为装钱后质量,e为空罐质量,v为f-e,n为硬币种类
    while(t--){
        scanf("%d%d%d",&e,&f,&n);
        v=f-e;
        for(int i=0;i<n;i++)
            scanf("%d%d",&price[i],&weight[i]);
        record[0]=0;
        for(int i=1;i<=v;i++)
            record[i]=INF;
        for(int i=0;i<n;i++){
            for(int j=weight[i];j<=v;j++){
                record[j]=min(record[j],record[j-weight[i]]+price[i]);
            }
        }
        if(record[v]<INF) //说明可以满足
            printf("The minimum amount of money in the piggy-bank is %d.\n",record[v]);
        else
            printf("This is impossible.\n");
    }
    return 0;
}

​

 

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1114

猜你喜欢

转载自blog.csdn.net/Krismile_/article/details/82531673
今日推荐