HDU - 1114 Piggy-Bank 【完全背包】

版权声明:记笔记~~~ https://blog.csdn.net/weixin_42765557/article/details/88085017

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1114

                                      Piggy-Bank

                       Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Problem Description

Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid.

But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs!

 

Input

The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams.

 

Output

Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line "This is impossible.".

Sample Input

3
10 110
2
1 1
30 50
10 110
2
1 1
50 30
1 6
2
10 3
20 4

Sample Output

The minimum amount of money in the piggy-bank is 60.
The minimum amount of money in the piggy-bank is 100.
This is impossible.

题意

有一个可以容纳最大重量为r的存钱罐,现在有n种硬币,每种重ci,价值wi。为是否能恰好装满存钱罐,如果能装满,装入的硬币的价值和最小是多少

解题思路

以最大容纳的硬币重量为背包容量,硬币重量为商品体积,硬币价值为商品价值。用数组Min[ i ]表示装入体积为i的商品时,所能得到的最小价值。初始化Min为无穷大,Min[ 0 ] 为 0 .最后如果Min[ 最大容量 ] = INF,说明以最大容量为下标的数组没被更改过,即没法装商品使得商品的总体积为最大容量,也即不可能装满背包,输出impossible,否则输出Min[ 最大容量 ].

AC代码

#include <iostream>
#include <algorithm>
#include <cstring> 
using namespace std;
const int INF = 0x3f3f3f3f;
struct Coin {
	int w,c;
}c[505]; 
int Min[10005];
int main()
{
	int T,l,r,n;
	cin >> T;
	
	while( T--)
	{
		cin >> l >> r;
		r = r-l;	//重量差(背包最大容量)
		cin >> n;
		for(int i=0;i<n;i++)
			cin >> c[i].w >>c[i].c; 
		
		memset(Min,INF,sizeof Min);
		Min[0] = 0;	
		for(int i=0;i<n;i++)
			for(int j=c[i].c;j<=r;j++)
				Min[j] = min(Min[j],Min[j-c[i].c]+c[i].w);
		if( Min[r] == INF)
			cout << "This is impossible.\n";
		else	
			cout << "The minimum amount of money in the piggy-bank is " << Max[r] << ".\n";
	}
	
	return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_42765557/article/details/88085017
今日推荐