F - Tournament(The 2018 ACM-ICPC Asia Qingdao Regional Contest)(找规律+构造)
Time limit:1000 ms
Memory limit:65536 kB
judge:
ZOJ - 4063
vjudge
Description
DreamGrid, the king of Gridland, is making a knight tournament. There are n n n knights, numbered from 1 to n n n, participating in the tournament. The rules of the tournament are listed as follows:
The tournament consists of k k k rounds. Each round consists of several duels. Each duel happens between exactly two knights.
Each knight must participate in exactly one duel during each round.
For each pair of knights, there can be at most one duel between them during all the k k k rounds.
Let 1 ≤ i , j ≤ k 1 \le i, j \le k 1≤i,j≤k, i ≠ j i \ne j i=j, and 1 ≤ a , b , c , d ≤ n 1 \le a, b, c, d \le n 1≤a,b,c,d≤n, a , b , c , d a, b, c, d a,b,c,d be four distinct integers. If
Knight a a a fights against knight b b b during round i i i, and
Knight c c c fights against knight d d d during round i i i, and
Knight a a a fights against knight c c c during round j j j,
then knight b b b must fight against knight d d d during round j j j.
As DreamGrid’s general, you are asked to write a program to arrange all the duels in all the k k k rounds, so that the resulting arrangement satisfies the rules above.
Input
There are multiple test cases. The first line of the input is an integer T T T, indicating the number of test cases. For each test case:
The first and only line contains two integers n n n and k k k ( 1 ≤ n , k ≤ 1000 1 \le n, k \le 1000 1≤n,k≤1000), indicating the number of knights participating in the tournament and the number of rounds.
It’s guaranteed that neither the sum of n n n nor the sum of k k k in all test cases will exceed 5000.
Output
For each test case:
If it’s possible to make a valid arrangement, output k k k lines. On the i i i-th line, output n n n integers c i , 1 , c i , 2 , … , c i , n c_{i, 1}, c_{i, 2}, \dots, c_{i, n} ci,1,ci,2,…,ci,n separated by one space, indicating that in the i i i-th round, knight j j j will fight against knight c i , j c_{i, j} ci,j for all 1 ≤ j ≤ n 1 \le j \le n 1≤j≤n.
If there are multiple valid answers, output the lexicographically smallest answer.
Consider two answers A A A and B B B, let’s denote a i , j a_{i, j} ai,j as the j j j-th integer on the i i i-th line in answer A A A, and b i , j b_{i, j} bi,j as the j j j-th integer on the i i i-th line in answer B B B. Answer A A A is lexicographically smaller than answer B B B, if there exists two integers p p p ( 1 ≤ p ≤ k 1 \le p \le k 1≤p≤k) and q q q ( 1 ≤ q ≤ n 1 \le q \le n 1≤q≤n), such that
for all 1 ≤ i < p 1 \le i < p 1≤i<p and 1 ≤ j ≤ n 1 \le j \le n 1≤j≤n, a i , j = b i , j a_{i, j} = b_{i, j} ai,j=bi,j, and
for all 1 ≤ j < q 1 \le j < q 1≤j<q, a p , j = b p , j a_{p, j} = b_{p, j} ap,j=bp,j, and finally a p , q < b p , q a_{p, q} < b_{p, q} ap,q<bp,q.
If it’s impossible to make a valid arrangement, output “Impossible” (without quotes) in one line.
Please, DO NOT output extra spaces at the end of each line, or your answer may be considered incorrect!
Sample Input
2
3 1
4 3
Sample Output
Impossible
2 1 4 3
3 4 1 2
4 3 2 1
题意
有 n n n 个骑士要参加 k k k 场比赛,每回合他们两两对决,对决过的两个骑士之后不能再次对决。但是这里有个要求:如果再某回合 A A A 对决 B B B , C C C 对决 D D D ,那么当某回合A对决 C ( D ) C(D) C(D) 时, B B B 要对决 D ( C ) D(C) D(C)。
如果能安排比赛,就输出对决安排,否则就输出Impossible
。
注意,输出的对决安排需要是字典序最小的。
题解
这道题需要找规律。下面给出n为8的表:
仔细观察可以发现发生调换的区间宽度刚好是 i i i的 l o w b i t ( i ) ∗ 2 lowbit(i) * 2 lowbit(i)∗2:
而且发现每次调换都是区间内对称的,这样就不难写出代码了。
而一个 n n n 可以构造出的全部的组合是 l o w b i t ( n ) − 1 lowbit(n)-1 lowbit(n)−1 ,如果所给的 k k k 大于这个值,就意味着这么多的安排是不存在的。
代码
#include <bits/stdc++.h>
#define maxn 1005
#define _for(i, a) for(int i = 0; i < (a); ++i)
#define _rep(i, a, b) for(int i = (a); i <= (b); ++i)
#define sc(x) scanf("%d", &x)
#define lowerbit(x) (x & (-x))
using namespace std;
int T, n, k, a[maxn];
void sol() {
if (k > lowerbit(n) - 1) {
printf("Impossible\n");
return;
}
_rep(i, 1, n) a[i] = i;
for (int i = 1; i <= k; ++i) {
int len = lowerbit(i);
for (int j = 1; j <= n; j += (len << 1)) {
_for(l, len) {
swap(a[j + l], a[j + len * 2 - 1 - l]);
}
}
_rep(j, 1, n) printf("%d%s", a[j], j == n ? "\n" : " ");
}
}
int main() {
while (cin >> T) {
_for(i, T) {
sc(n), sc(k);
sol();
}
}
return 0;
}