PAT--1086 Tree Traversals Again (25 分)

1086 Tree Traversals Again (25 分)

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.


Figure 1

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop

Sample Output:

3 4 2 6 5 1
#include<bits/stdc++.h>
using namespace std;
const int maxn = 50;
struct TreeNode
{
    int data;
    TreeNode* lchild;
    TreeNode* rchild;
};

int pre[maxn],post[maxn],in[maxn];
int n;
int postFlag = 0;

TreeNode* create(int preL,int preR,int inL,int inR){
    if(preL>preR){
        return NULL;
    }
    TreeNode* root = new TreeNode;
    root->data = pre[preL];
    int k;
    for(k=inL;k<=inR;k++){
        if(in[k]==pre[preL]){
            break;
        }
    }
    int numLeft = k-inL;

    root->lchild = create(preL+1,preL+numLeft,inL,k-1);
    root->rchild = create(preL+numLeft+1,preR,k+1,inR);

    return root;
}

void postOrder(TreeNode* root){
    if(root==NULL){
        return;
    }
    postOrder(root->lchild);
    postOrder(root->rchild);
    post[postFlag++] = root->data;
}
int main()
{
    stack<int> s;
    cin>>n;
    getchar();
    string ss;
    int inflag = 0,preflag = 0;
    for(int i=0;i<2*n;i++)
    {
        getline(cin,ss);
        int a = 0;
        if(ss.length()>4)
        {
            //int length = ss.length();
            for(int i=5; i<ss.length(); i++)
            {
                //cout<<ss[i];
                int c = ss[i]-'0';
                a =a*10+c;
            }
            s.push(a);
            pre[preflag++] = a;

        }else{
            int b = s.top();
            in[inflag++] = b;
            s.pop();
        }
    }

    TreeNode* root = create(0,n-1,0,n-1);

    postOrder(root);

    for(int i=0;i<postFlag;i++){
        cout<<post[i];
        if(i!=postFlag-1)
            cout<<" ";
    }

    return 0;
}

猜你喜欢

转载自blog.csdn.net/jackson_j/article/details/100183517
今日推荐