1086. Tree Traversals Again (25)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/zs391077005/article/details/79086207


时间限制
200 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.


Figure 1

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop
Sample Output:
3 4 2 6 5 1

提交代码

#include<fstream>
#include <cstdio>
#include <iostream>
#include<algorithm>
#include<set>
#include<map>
#include<vector>
#include<string>
#include<cmath>
#include<stack>
using namespace std;
vector<int> pre,in,post;
void postorder(int root,int start,int end)
{
	if(start>end) return ;
	int i=start;
	while(i<end&&pre[root]!=in[i])
		i++;
	postorder(root+1,start,i-1);
	postorder(i-start+root+1,i+1,end);
	post.push_back(pre[root]);
}
int main()
{
	int n;
	cin>>n;
	string str;
	stack<int> s;
	for(int i=0;i<2*n;i++)
	{
		cin>>str;
		if(str.length()==4)
		{
			int num;
			scanf("%d",&num);
			pre.push_back(num);
			s.push(num);
		}
		else{
			in.push_back(s.top());
			s.pop();
		}
	}
	postorder(0,0,n-1);
	printf("%d",post[0]);
	for(int i=1;i<n;i++)
		printf(" %d",post[i]);
#ifdef _DEBUG
	system("pause");
#endif	


	return 0;
	
}


猜你喜欢

转载自blog.csdn.net/zs391077005/article/details/79086207
今日推荐