【PAT】A1086. Tree Traversals Again (25)

Description:
An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.

Snip20160811_80


Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: “Push X” where X is the index of the node being pushed onto the stack; or “Pop” meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop


Sample Output:
3 4 2 6 5 1

//NKW 甲级练习题
#pragma warning(disable:4996)
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <stack>
using namespace std;
stack<int> st;
int n, temp, cnt = 0, cnt1 = 0, cnt2 = 0, inorder[31], preorder[31];
char ins[10];
typedef struct Node{
	int data;
	Node* lchild, *rchild;
}node, *nodep;
nodep build(int prel, int prer, int inl, int inr){
	if (prel > prer)	return NULL;
	if (prel > n - 1)	return NULL;
	node* root = (node*)malloc(sizeof(node));
	root->data = preorder[prel];
	int i = inl;
	for (i = inl; i <= inr; i++)
		if (inorder[i] == preorder[prel])
			break;
	int a = i - inl;
	root->lchild = build(prel + 1, prel + a, inl, i);
	root->rchild = build(prel + a + 1, prer, i + 1, inr);
	return root;
}
void postorder(nodep root){
	if (root == NULL)	return;
	postorder(root->lchild);
	postorder(root->rchild);
	printf("%d", root->data);
	if (++cnt < n)	printf(" ");
}
int main(){
	scanf("%d", &n);
	for (int i = 0; i < 2 * n; i++){
		scanf("%s", ins);
		if (strlen(ins) == 4){
			scanf("%d", &temp);
			preorder[cnt1++] = temp;
			st.push(temp);
		}
		else{
			inorder[cnt2++] = st.top();
			st.pop();
		}
	}
	nodep root = build(0, n - 1, 0, n - 1);
	postorder(root);
	printf("\n");
	system("pause");
	return 0;
}

有一点小问题,先标记了

猜你喜欢

转载自blog.csdn.net/ztmajor/article/details/81461691
今日推荐