Identity Card
题目来源:杭电ACM
原题描述:
Problem Description
Do you own an ID card?You must have a identity card number in your family’s Household Register. From the ID card you can get specific personal information of everyone. The number has 18 bits,the first 17 bits contain special specially meanings:the first 6 bits represent the region you come from,then comes the next 8 bits which stand for your birthday.What do other 4 bits represent?You can Baidu or Google it. Here is the codes which represent the region you are in.
However,in your card,maybe only 33 appears,0000 is replaced by other
numbers. Here is Samuel’s ID number 331004198910120036 can you tell
where he is from?The first 2 numbers tell that he is from Zhengjiang
Province,number 19891012 is his birthday date (yy/mm/dd).
.
Input
Input will contain 2 parts: A number n in the first line,n here
means there is n test cases. For each of the test cases,there is a
string of the ID card number.
.
Output
Based on the table output where he is from and when is his
birthday. The format you can refer to the Sample Output.
.
Sample Input
1
330000198910120036
.
Sample Output
He/She is from Zhejiang,and his/her birthday is on 10,12,1989 based on the table.
.
Author
Samuel
.
Source
灰色橙子 专场
.
Recommend
zty
代码
/*
作者:童话
环境:Win 10 & Visual Studio 2019
时间:2021-3-12
*/
#define _CRT_SECURE_NO_WARNINGS
#include <stdio.h>
int main(void)
{
int n; //测试样例变量
char id[20]; //身份证号码
int i;
char relation[8][10] = {
{
"Beijing"},
{
"Liaoning"},
{
"Shanghai"},
{
"Zhejiang"},
{
"Tibet" },
{
"Taiwan"},
{
"Hong Kong"},
{
"Macao"} };
int label[8] = {
11,21,31,33,54,71,81,82 };
(void)scanf("%d", &n);
while (n--)
{
(void)scanf("%s", id);
int diqu = 0;
int year = 0;
//求出地区对应的代号
for (i = 0; i < 2; i++)
diqu = diqu * 10 + id[i] - '0';
//求出出生年份
for (i = 6; i < 10; i ++ )
year = year * 10 + id[i] - '0';
//求出地区代号对应的省份名称
for (i = 0; i < 8; i++)
if (diqu == label[i])
break;
printf("He/She is from %s,and his/her birthday is on %c%c,%c%c,%d based on the table.\n", relation[i],id[10], id[11], id[12], id[13],year);
}
return 0;
}
小结一下
这题的思路就是用字符数组的方式去处理身份证号码,可以随性的跳着处理字符(求地区和年份时),输出也可以直接输出对应位置的数字。
·
·
·
附: 另一种系统没通过但是输出结果目测没有问题的代码
#define _CRT_SECURE_NO_WARNINGS
#include <stdio.h>
int main(void)
{
int n; //测试样例变量
int region; //地区变量
int year;
int month;
int day;
int i;
char relation[8][10] = {
{
"Beijing"},
{
"Liaoning"},
{
"Shanghai"},
{
"Zhejiang"},
{
"Tibet" },
{
"Taiwan"},
{
"Hong Kong"},
{
"Macao"} };
int label[8] = {
11,21,31,33,54,71,81,82 };
(void)scanf("%d", &n);
while (n--)
{
(void)scanf("%2d", ®ion);
(void)scanf("%4d", &i);
(void)scanf("%4d", &year);
(void)scanf("%2d", &month);
(void)scanf("%2d", &day);
(void)scanf("%4d", &i);
for (i = 0; i < 8; i++)
if (region == label[i])
break;
printf("He/She is from %s,and his/her birthday is on %d,%d,%d based on the table.\n", relation[i], month, day, year);
}
return 0;
}