poj-2492(种类并查集)

Description

Background 
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs. 
Problem 
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.
Input

The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.
Output

The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.


Sample Input

2
3 3
1 2
2 3
1 3
4 2
1 2
3 4
Sample Output

Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!

 题目意思就是 给定n只虫子 不同性别的可以在一起 相同性别的不能在一起
给你m对虫子 判断中间有没有同性别在一起的;
我们把同性的放到一个集合里 如果一个集合里出现了异性 则说明存在同性恋在一起
假设 x 为一种性别 x+n为与其相反的性别  
若a,b为同性 的  我们则可以判断 (a,b+n)  (b,a+n)为异性,反之亦然;

#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
const int maxn = 5000;
int par[maxn];
void init(int n){
   for(int i=0;i<=n;i++)
      par[i]=i;
}
int find(int x){
    if(x!=par[x])
        par[x]=find(par[x]);
    return par[x];
}
void Union(int a,int b){
    int x=find(a);
    int y=find(b);
    if(x!=y)
       par[x]=y;
}
bool judge(int x,int y){//判断是否为同性,异性为真,同性为假
   x=find(x);
   y=find(y);
   if(x!=y)
    return true;
   return false;
}
int main()
{
    int t,n,m,cas=1;
    scanf("%d",&t);
    for(int i=1;i<=t;i++){
        scanf("%d%d",&n,&m);
        init(n*2);
        bool l=1;
        int x,y;
        while(m--){
            scanf("%d%d",&x,&y);
            if(judge(x,y)||judge(x+n,y+n)){
                Union(x,y+n);//把同性的加到一个集合里
                Union(x+n,y);
            }
            else
                l=0;
        }
        if(i!=1)
            puts("");
        printf("Scenario #%d:\n",cas++);
        if(l)
            printf("No suspicious bugs found!\n");
        else
            printf("Suspicious bugs found!\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_24016309/article/details/88727423