Shift Dot

Time Limit: 1000 ms Memory Limit: 65536 KiB
Submit Statistic
Problem Description
给出平面直角坐标系中的一点,并顺序给出n个向量,求该点根据给定的n个向量位移后的位置。

Input
多组输入,第一行是三个整数x,y,n,表示点的坐标(x,y),和向量的个数n。接下来n行,每行两个数xi,yi,表示第i个向量。题目中所有数据不会超出整形范围。
Output
每组输入输出一行,”(x,y)”表示点的最终位置。
Sample Input
0 0 1
2 3
0 0 2
1 2
2 3
Sample Output
(2,3)
(3,5)
Hint

Source

import java.util.*;

class myclass {

}

class Main {
    public static void main(String[] args) {

        Scanner ss = new Scanner(System.in);
        //int n;// , m;
        final int mm = 205;
        int x, y, n;
        while (ss.hasNextLine()) {
            x = ss.nextInt();
            y = ss.nextInt();
            n = ss.nextInt();
            int xx, yy;
            while(n > 0) {
                xx = ss.nextInt();
                yy = ss.nextInt();
                x += xx;
                y+= yy;
                n--;
            }
            System.out.printf("(%d,%d)\n", x, y);
        }
        ss.close();
    }
}

猜你喜欢

转载自blog.csdn.net/weiwjacsdn/article/details/80171698
dot