POJ-1631 Bridging signals ((nlogn)的最长上升子序列)

Bridging signals
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 15667   Accepted: 8467

Description

'Oh no, they've done it again', cries the chief designer at the Waferland chip factory. Once more the routing designers have screwed up completely, making the signals on the chip connecting the ports of two functional blocks cross each other all over the place. At this late stage of the process, it is too expensive to redo the routing. Instead, the engineers have to bridge the signals, using the third dimension, so that no two signals cross. However, bridging is a complicated operation, and thus it is desirable to bridge as few signals as possible. The call for a computer program that finds the maximum number of signals which may be connected on the silicon surface without crossing each other, is imminent. Bearing in mind that there may be thousands of signal ports at the boundary of a functional block, the problem asks quite a lot of the programmer. Are you up to the task? 

A typical situation is schematically depicted in figure 1. The ports of the two functional blocks are numbered from 1 to p, from top to bottom. The signal mapping is described by a permutation of the numbers 1 to p in the form of a list of p unique numbers in the range 1 to p, in which the i:th number specifies which port on the right side should be connected to the i:th port on the left side.Two signals cross if and only if the straight lines connecting the two ports of each pair do.

Input

On the first line of the input, there is a single positive integer n, telling the number of test scenarios to follow. Each test scenario begins with a line containing a single positive integer p < 40000, the number of ports on the two functional blocks. Then follow p lines, describing the signal mapping:On the i:th line is the port number of the block on the right side which should be connected to the i:th port of the block on the left side.

Output

For each test scenario, output one line containing the maximum number of signals which may be routed on the silicon surface without crossing each other.

Sample Input

4
6
4
2
6
3
1
5
10
2
3
4
5
6
7
8
9
10
1
8
8
7
6
5
4
3
2
1
9
5
8
9
2
3
1
7
4
6

Sample Output

3
9
1
4

Source

#include<cstdio>
#include<cstring>
#define MAXN 40010
int a[MAXN],dp[MAXN],len;//memset
/*dp存的是长度为k的上升子序列的最末元素,若有多个长度为k的上升子序列,则记录最小的那个最末元素。
首先len = 1,dp[1] = a[1],然后对a[i]:若a[i]>dp[len],那么len++,dp[len] = a[i];
否则,我们要从dp[1]到d[len-1]中找到一个j,满足d[j-1]<a[i]<d[j],则根据D的定义,我们需要更新长度为j的上升子序列的最末元素(使之为最小的)即 dp[j] = a[i];
最终答案就是len
利用d的单调性,在查找j的时候可以二分查找,从而时间复杂度为nlogn。*/
int binary_search(int x)
{
	int left,right,mid;
	left=1,right=len;
	while(left<=right)
    {
		mid=left+(right-left)/2;
		if(dp[mid]>=a[x])  //等于看成是小于
        right=mid-1;
		else
		left=mid+1;
	}
	return left;//不管最后是left+1,还是right-1 return的都是left
}
int main()
{
	int t,n,i;
	scanf("%d",&t);
	while(t--)
    {
        memset(dp,0,sizeof(dp));
        memset(a,0,sizeof(a));
		scanf("%d",&n);
		for(i=1;i<=n;i++)
        scanf("%d",&a[i]);
		dp[1]=a[1];
		len=1;
		for(i=2;i<=n;i++)
        {
			if(a[i]>dp[len])
            dp[++len]=a[i];
			else
			{
				int pos=binary_search(i);   // 如果用STL: lower_bound(dp+1,dp+len,a[i])-dp
				dp[pos]=a[i];
		     }
        }
		printf("%d\n",len);
	}
	return 0;
}



猜你喜欢

转载自blog.csdn.net/xigongdali/article/details/81028954