UVa 1225 - Digit Counting


1225 - Digit Counting

Time limit: 3.000 seconds
Trung is bored with his mathematics homeworks. He takes a piece of chalk and starts writing a sequenceof consecutive integers starting with 1 to N (1 < N < 10000). After that, he counts the number oftimes each digit (0 to 9) appears in the sequence.
For example, with N = 13, the sequence is:12345678910111213In this sequence, 0 appears once, 1 appears 6 times, 2 appears 2 times, 3 appears 3 times, and eachdigit from 4 to 9 appears once.
After playing for a while, Trung gets bored again. He now wants towrite a program to do this for him. Your task is to help him with writing this program.
Input
The input file consists of several data sets. The first line of the input file contains the number of datasets which is a positive integer and is not bigger than 20. The following lines describe the data sets.For each test case, there is one single line containing the number N.
Output
For each test case, write sequentially in one line the number of digit 0, 1, . . . 9 separated by a space.
Sample Input
2
3
13
Sample Output
0 1 1 1 0 0 0 0 0 0
1 6 2 2 1 1 1 1 1 1

思路
  1. 难点在于有多位数字的时候转换为字符串输出
#include<iostream>
#include<cstring>
using namespace std;

int main()
{
    int a[15];        //%10得到的数为0~9,所以数组长度10即可,大一点没关系
    int t,n;
    cin>>t;
    while(t--)
    {
        memset(a,0,sizeof(a));
        cin>>n;
        for(int i=1;i<=n;i++)
        {
            int x=i;
            while(x)
            {
                int num=x%10;
                a[num]++;        //打表,只要出现与下标相同的数字,就+1
                x/=10;        
            }
        }
        for(int i=0;i<10;i++)    
        {
            if(i)cout<<" ";        //记住该方法!!!
            cout<<a[i];
        }
        cout<<endl;
    }
    return 0;
}


猜你喜欢

转载自blog.csdn.net/qq_38735931/article/details/81055517