Digit Counting UVA - 1225

Trung is bored with his mathematics homeworks. He takes a piece of chalk and starts writing a sequence
of consecutive integers starting with 1 to N (1 < N < 10000). After that, he counts the number of
times each digit (0 to 9) appears in the sequence. For example, with N = 13, the sequence is:
12345678910111213
     In this sequence, 0 appears once, 1 appears 6 times, 2 appears 2 times, 3 appears 3 times, and each
digit from 4 to 9 appears once. After playing for a while, Trung gets bored again. He now wants to
write a program to do this for him. Your task is to help him with writing this program.

Input
The input file consists of several data sets. The first line of the input file contains the number of data
sets which is a positive integer and is not bigger than 20. The following lines describe the data sets.
     For each test case, there is one single line containing the number N.

Output
For each test case, write sequentially in one line the number of digit 0, 1, . . . 9 separated by a space.
Sample Input
2
3
13
Sample Output
0 1 1 1 0 0 0 0 0 0
1 6 2 2 1 1 1 1 1 1

题目大意:数数字

把前n(n≤10000)个整数顺次写在一起:123456789101112…数一数0~9各出现多少次(输出10个整数,分别是0,1,…,9出现的次数)。

#include <stdio.h>
int main()
{
    int n,x,i;
    scanf("%d",&x);
    while(x--)
    {
        int num[10]={0};
        scanf("%d",&n);
        for(i=1;i<=n;i++)
        {
            if(i<10)
                num[i]++;
            else if(i<100)
            {
                num[i/10]++;
                num[i%10]++;
            }
            else if(i<1000)
            {
                num[i/100]++;
                num[(i/10)%10]++;
                num[i%10]++;
            }
            else if(i<10000)
            {
                num[i/1000]++;
                num[(i/100)%10]++;
                num[(i/10)%10]++;
                num[i%10]++;
            }
        }
        for(i=0;i<=9;i++)
        {
            if(i==0) 
				printf("%d",num[0]);
            else 
				printf(" %d",num[i]);
        }
        printf("\n");
    }
    return 0;
}

数组的简单题,统计出现次数存入数组,暴力求解,简单粗暴,数据不大不用担心超限问题。

猜你喜欢

转载自blog.csdn.net/yuxiangmitu/article/details/81164796