UVA1225 Digit Counting【基础题】

Trung is bored with his mathematics homeworks. He takes a piece of chalk and starts writing a sequenceof consecutive integers starting with 1 to N (1 < N < 10000). After that, he counts the number oftimes each digit (0 to 9) appears in the sequence. For example, with N = 13, the sequence is:

12345678910111213

  In this sequence, 0 appears once, 1 appears 6 times, 2 appears 2 times, 3 appears 3 times, and eachdigit from 4 to 9 appears once. After playing for a while, Trung gets bored again. He now wants towrite a program to do this for him. Your task is to help him with writing this program.

Input

The input file consists of several data sets. The first line of the input file contains the number of datasets which is a positive integer and is not bigger than 20. The following lines describe the data sets.For each test case, there is one single line containing the number N.

Output

For each test case, write sequentially in one line the number of digit 0, 1, . . . 9 separated by a space.

Sample Input

2

3

13

扫描二维码关注公众号,回复: 897362 查看本文章

Sample Output

0 1 1 1 0 0 0 0 0 0

1 6 2 2 1 1 1 1 1 1

题意:统计一串数字中0—9出现的次数。
AC代码:
#include<stdio.h>
#include<string.h>
int main(void)
{
	int a[10];
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int i;
		memset(a,0,sizeof(a));
		int n;
		scanf("%d",&n);
		int m;
		int num;
		for(i = 1; i <= n; i++)
		{
			m = i;
			while(m)
			{
				num = m%10;  
                a[num]++;  
                m /= 10; 
			}
		}
		for(i = 0; i < 9; i++)
			printf("%d ",a[i]);
		printf("%d\n",a[9]);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/wxd1233/article/details/80344034