UVA10815(set运用)

Description

Andy, 8, has a dream - he wants to produce his very own dictionary. This is not an easy task for him, as the number of words that he knows is, well, not quite enough. Instead of thinking up all the words himself, he has a briliant idea. From his bookshelf he would pick one of his favourite story books, from which he would copy out all the distinct words. By arranging the words in alphabetical order, he is done! Of course, it is a really time-consuming job, and this is where a computer program is helpful.

You are asked to write a program that lists all the different words in the input text. In this problem, a word is defined as a consecutive sequence of alphabets, in upper and/or lower case. Words with only one letter are also to be considered. Furthermore, your program must be CaSe InSeNsItIvE. For example, words like "Apple", "apple" or "APPLE" must be considered the same.

Input

The input file is a text with no more than 5000 lines. An input line has at most 200 characters. Input is terminated by EOF.

Output

Your output should give a list of different words that appears in the input text, one in a line. The words should all be in lower case, sorted in alphabetical order. You can be sure that he number of distinct words in the text does not exceed 5000.

Sample Input

Adventures in Disneyland

Two blondes were going to Disneyland when they came to a fork in the
road. The sign read: "Disneyland Left."

So they went home.

Sample Output

a
adventures
blondes
came
disneyland
fork
going
home
in
left
read
road
sign
so
the
they
to
two
went
were

题解打完蓝桥后就没有写代码了感觉生疏了好多,这题题目有点坑。刚开始也不知道自己错的哪里

坑点在于比如455yui456  输出的是yui     45676.6465 没有输出 其他没有啥了 还有就是set的运用 搜了博客才知道是自动排序的

emmm还有自己的string类一些函数的运用还是有毛病奥............

扫描二维码关注公众号,回复: 2295264 查看本文章

代码:

#include<bits/stdc++.h>
using namespace std;
set<string>s;
int main()
{
	char str[205]; 
	string tt="",ss="";
	while(scanf("%s",str)!=EOF)
	{
		int len=strlen(str);	
		for(int i=0;i<len;i++)
		{
			if(isalpha(str[i]))//是字符 
			{
				if(str[i]>='A'&&str[i]<='Z')
				str[i]+=32;//先转换成小写的 
				
				if(str[i]>='a'&&str[i]<='z')
					tt+=str[i]; 
			}else
			{
				if(tt.empty())continue;
				s.insert(tt); 
				tt.clear();
			} 
		} 
			if(!tt.empty())
			{
				s.insert(tt); 
				tt.clear();
			}
	}

	set<string>::iterator it=s.begin();//包括去重 
	while(it!=s.end())
	{
		cout<<*it<<endl;
		it++;
	}
	return 0;
} 

猜你喜欢

转载自blog.csdn.net/galesaur_wcy/article/details/81092439