Uva 10815(set)

版权声明:禁止盗用 https://blog.csdn.net/weixin_43411988/article/details/89174830

输入一个文本,找出所有不同的单词(连续的字母序列),按字典序从小到大输出。单词不区分大小写。
样例输入:
Adventures in Disneyland
Two blondes were going to Disneyland when they came to a fork in the
road. The sign read: “Disneyland Left.”
So they went home.

样例输出(为了节约篇幅只保留前5行):
a
adventures
blondes
came
disneyland

【分析】
本题没有太多的技巧,只是为了展示set的用法:由于string已经定义了“小于”运算符,直接使用set保存单词集合即可。注意,输入时把所有非字母的字符变成空格,然后利用stringstream得到各个单词。

#include <bits/stdc++.h>

using namespace std;

set<string> dict;

int main() {
	string s,buf;
	while (cin >> s) {
		for (int i = 0; i < (int) s.length(); i++) {
			if (isalpha(s[i]))
				s[i] = tolower(s[i]);
			else
				s[i] = ' ';
		}
		stringstream ss(s);
		while (ss>>buf) {
			dict.insert(buf);
		}
	}
	for (set<string>::iterator it = dict.begin(); it != dict.end(); ++it)
		cout<<*it<<endl;
	return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_43411988/article/details/89174830
今日推荐