数据结构实验之链表六:有序链表的建立

Problem Description
输入N个无序的整数,建立一个有序链表,链表中的结点按照数值非降序排列,输出该有序链表。
Input
第一行输入整数个数N;
第二行输入N个无序的整数。
Output
依次输出有序链表的结点值。
Sample Input
6
33 6 22 9 44 5
Sample Output
5 6 9 22 33 44

#include <stdio.h>
#include <stdlib.h>
struct node
{
    int data;
    struct node *next;
};
struct node *head;
struct node *creat(int n)
{
   struct node *tail,*p;
   head=(struct node *)malloc(sizeof(struct node));
   head->next =NULL;
   tail=head;
   while(n)
   {
       p=(struct node *)malloc(sizeof(struct node));
       scanf("%d",&p->data);
       p->next=NULL;
       tail->next=p;
       tail=p;
       n--;
   }
   return head;
}

void sort(struct node *head)
{
    struct node *p,*q;
    int t;
    for(p=head->next;p!=NULL;p=p->next)
    {
        for(q=p->next;q!=NULL;q=q->next)
        {
            if(p->data>q->data)
            {
                t=p->data;
                p->data=q->data;
                q->data=t;
            }
        }
    }
}

void print(struct node *head)
{
    struct node *p;
    p=head->next;
    while(p!=NULL)
    {
        printf("%d",p->data);
        if(p->next!=NULL)
        {
            printf(" ");
        }
        else
            printf("\n");
        p=p->next;
    }
}

int main()
{
    int N;
    scanf("%d",&N);
    head=creat(N);
    sort(head);
    print(head);
    return 0;
}

选择排序做的。

猜你喜欢

转载自blog.csdn.net/qq_41341757/article/details/81748783