floyd+记录路径

B - Minimum Transport Cost

These are N cities in Spring country. Between each pair of cities there may be one transportation track or none. Now there is some cargo that should be delivered from one city to another. The transportation fee consists of two parts: 
The cost of the transportation on the path between these cities, and 

a certain tax which will be charged whenever any cargo passing through one city, except for the source and the destination cities. 

You must write a program to find the route which has the minimum cost. 

Input

First is N, number of cities. N = 0 indicates the end of input. 

The data of path cost, city tax, source and destination cities are given in the input, which is of the form: 

a11 a12 ... a1N 
a21 a22 ... a2N 
............... 
aN1 aN2 ... aNN 
b1 b2 ... bN 

c d 
e f 
... 
g h 

where aij is the transport cost from city i to city j, aij = -1 indicates there is no direct path between city i and city j. bi represents the tax of passing through city i. And the cargo is to be delivered from city c to city d, city e to city f, ..., and g = h = -1. You must output the sequence of cities passed by and the total cost which is of the form: 

Output

From c to d : 
Path: c-->c1-->......-->ck-->d 
Total cost : ...... 
...... 

From e to f : 
Path: e-->e1-->..........-->ek-->f 
Total cost : ...... 

Note: if there are more minimal paths, output the lexically smallest one. Print a blank line after each test case. 
 

Sample Input

5
0 3 22 -1 4
3 0 5 -1 -1
22 5 0 9 20
-1 -1 9 0 4
4 -1 20 4 0
5 17 8 3 1
1 3
3 5
2 4
-1 -1
0

Sample Output

From 1 to 3 :
Path: 1-->5-->4-->3
Total cost : 21

From 3 to 5 :
Path: 3-->4-->5
Total cost : 16

From 2 to 4 :
Path: 2-->1-->5-->4
Total cost : 17

题意:给你每个点到另一个点的距离,然后给你起点和终点,要你求最小路径,并记录路径,如果最小路径不止一条,输出字典序最小的。

分析:关键在于记录路径,用res[i][j]表示以i为起点的路径的终点,初始化时res[i][j]=j

然后松弛时不断更新res[i][j]

AC code:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<map>
using namespace std;
const int maxn=205;
const int INF=0x3f3f3f3f;
map<string,int>p;
int path[maxn][maxn];
int res[maxn][maxn];///记录路径,res[i][j]表示以i为起点的这条路的终点
int cost[maxn];
int n;
void init()
{
    for(int i=1;i<=n;i++)
        for(int j=1;j<=i;j++)
         if(i==j) path[i][j]=0;
         else path[i][j]=path[j][i]=INF;
}
void floyd()
{
    for(int k=1;k<=n;k++)
        for(int i=1;i<=n;i++)
          for(int j=1;j<=n;j++)
            if(path[i][j]>path[i][k]+path[k][j]+cost[k])
               path[i][j]=path[i][k]+path[k][j]+cost[k],res[i][j]=res[i][k];///i->j的道路可以通过i->k,k->j松驰,松弛i->j
                                                                ///此时i->j这条路径的终点为i->k这条路径的终点
            else if(path[i][j]==path[i][k]+path[k][j]+cost[k]&&res[i][j]>res[i][k])
               res[i][j]=res[i][k];///当花费相同时,按字典顺序排序
}
int main()
{
    while(scanf("%d",&n),n){
    init();
    for(int i=1;i<=n;i++)
        for(int j=1;j<=n;j++){
          scanf("%d",&path[i][j]);
          if(path[i][j]==-1)
             path[i][j]=INF;
          res[i][j]=j;///
        }
        for(int i=1;i<=n;i++)
            scanf("%d",&cost[i]);
        floyd();
        int s,e;
        while(scanf("%d%d",&s,&e)!=EOF&&s!=-1||e!=-1)
        {
            printf("From %d to %d :\nPath: %d",s,e,s);
            int u=s,v=e;
            while(u!=v){///u==v表示到达最后终点
            printf("-->%d",res[u][v]);
            u=res[u][v];///依次以u为起点得到终点,再又以之为起点,递推出路径
            }
            printf("\nTotal cost : %d\n\n",path[s][e]);
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/shaohang_/article/details/81710771