实验三 Java基本程序设计(2)

                                         实验三 Java基本程序设计(2)

                                          实验时间 2018-9-13

、实验目的与要求

1)进一步掌握Eclipse集成开发环境下java程序开发基本步骤;

2)熟悉PTA平台线上测试环境;

3)掌握Java语言构造基本程序语法知识(ch1-ch3);

4)利用已掌握Java语言基本程序设计知识,学习设计开发含有一个主类、类内可有多个方法的应用程序。

2、实验内容和步骤

实验1:采用个人账号登录https://pintia.cn/使用邀请码588329加入PTA平台NWNU-2017NISE教学班(西北师范大学 计算机科学与工程学院 2017级 网络与信息安全),完成《2018秋季西北师范大学面向对象程序设计(Java)(ch1-ch3)测试题1》,测试时间120分钟;

实验2-实验3在课后完成

实验2公民身份证号码按照GB11643—1999《公民身份证号码》国家标准编制,由18位数字组成:前6位为行政区划分代码,第7位至14位为出生日期码,第15位至17位为顺序码,第18位为校验码。从键盘输入1个身份证号,将身份证号的年月日抽取出来,按年-月-日格式输出。注意:输入使用Scanner类nextLine()方法,以免出错。

输入样例:

34080019810819327X

输出样例:

1981-08-19

实验结果如下:

import java.util.Scanner;
public class ID1 {
public static void main(String[] args)
{
System.out.println("请输入身份证号18位!");
Scanner scanner=new Scanner(System.in);
String ID=scanner.nextLine();
while(ID.length()!=18)
{
System.out.println("身份证号码必须是18位");
ID=scanner.nextLine();
}
int i=6;
String year = ID.substring(i,i+4);
String month=ID.substring(i+4,i+6);
String day=ID.substring(i+6,i+8);
System.out.println(year+"-"+month+"-"+day);
}
}

实验可能出现的两种结果如下图所示:

实验3studentfile.txt文件内容是本班同学的学号与姓名,利用此文件编制一个程序,将studentfile.txt文件的信息读入到内存,并提供两类查询功能:(1)输入姓名查询学号;(2)输入学号查询姓名。要求程序具有友好人机交互界面。

 实验出现的结果如下图所示:

package students;


import java.io.BufferedReader;
import java.io.File;
import java.io.FileReader;
import java.io.IOException;
import java.util.ArrayList;
import java.util.Scanner;

public class Test {

    private static ArrayList<Student> studentList = null;


    public static void StudentsFromFile(String fileName){
        File file = new File(fileName);
        BufferedReader reader = null;
        try {
            reader = new BufferedReader(new FileReader(file));
            String tempString = null;
            while ((tempString = reader.readLine()) != null) {
                String str[] = tempString.split(" ");
                if(studentList != null && str.length > 1) {
                    Student student = new Student();
                    student.setStudentId(str[0]);
                    student.setName(str[1]);
                    studentList.add(student);
                }
            }
            reader.close();
        } catch (IOException e) {
            e.printStackTrace();
        } finally {
            if (reader != null) {
                try {
                    reader.close();
                } catch (IOException e1) {
                }
            }
        }
    }


    public static String findStudentIdByName(String name) {
        String studentId = null;
        for(Student student : studentList) {
            if(student.getName().equals(name)) {
                studentId = student.getStudentId();
                break;
            }
        }
        return studentId;
    }
    public static String findStudentNameById(String ID) {
        String studentName = null;
        for(Student student : studentList) {
            if(student.getStudentId().equals(ID)) {
                studentName = student.getName();
                break;
            }
        }
        return studentName;
    }
    public static void main(String args[]) {
        String path = "D:/studentfile.txt";
        studentList = new ArrayList<Student>();
        StudentsFromFile(path);
        int statu = 1;
        System.out.println();
        while(statu != 0) {
            System.out.println("******************");
            System.out.println("1:Select StudentId By StudentName");
            System.out.println("2:Select StudentName by StudentId");
            System.out.println("0:exit");
            System.out.println("******************");
            Scanner scanner = new Scanner(System.in);
            statu = scanner.nextInt();
            switch(statu) {
                case 1:{
                    System.out.println("Please input student name:");
                    Scanner scanner1 = new Scanner(System.in);
                    String name = scanner1.nextLine();
                    String Id = findStudentIdByName(name);
                    if(Id != null) {
                        System.out.println("Name: "+name+" Id: "+Id);
                    }else {
                        System.out.println("Don`t has this student");
                    }

                }break;
                case 2:{
                    System.out.println("Please input student Id:");
                    Scanner scanner2 = new Scanner(System.in);
                    String Id = scanner2.nextLine();
                    String name = findStudentNameById(Id);
                    if(name != null) {
                        System.out.println("name: "+name+" Id: "+Id);
                    }else {
                        System.out.println("Don`t has this student");
                    }
                }break;
                case 0:
                    statu = 0; break;
                default:
                    System.out.println("input error");
            }
        }
        System.out.println("byebye!");
    }
}

编程建议:

1)从文件中读入学生信息,可以编写如下函数:

public static void StudentsFromFile(String fileName))

2)输入姓名查找学生学号,可以编写如下函数:

public static String findStudent(String name)

(3)输入学号查找学生姓名,可以编写如下函数:

public static String findStudent(String ID)

实验总结:

        在本周的学习过程中,没有学习新的内容,有学习了第三章剩下的内容,而且还间接复习了一下前三章的内容,只是这个复习不同于以往的形式,在原来学的理论知识的基础上,在周四下午我们进行了一场考试。在考试的过程当中我明确的发现自己在Java知识方面掌握的不足,尤其在变成这一块,我觉得自己还是有待进一步提高,因为在考试有四道变成题目,有两道题目没做出来,其他两道题目还是通过查询资料所写出来的。

       在考试过程中遇到了好多问题,尤其是在编程序这一方面,在程序测试平台上所运行的结果跟平常是不一样的,在这个平台上只有在运行的时候才会提示错误,而且不会提示错误到具体的一个地方,所以说在以后的学习过程中就要求我对基础知识的掌握的程度就得更准确。

猜你喜欢

转载自www.cnblogs.com/791683057mxd/p/9650840.html