1096 Consecutive Factors

1096 Consecutive Factors
1096 Consecutive Factors (20 分)
Among all the factors of a positive integer N, there may exist several consecutive numbers. For example, 630 can be factored as 3×5×6×7, where 5, 6, and 7 are the three consecutive numbers. Now given any positive N, you are supposed to find the maximum number of consecutive factors, and list the smallest sequence of the consecutive factors.

Input Specification:
Each input file contains one test case, which gives the integer N (1<N<2
​31
​​ ).

Output Specification:
For each test case, print in the first line the maximum number of consecutive factors. Then in the second line, print the smallest sequence of the consecutive factors in the format factor[1]factor[2]…*factor[k], where the factors are listed in increasing order, and 1 is NOT included.

Sample Input:
630
Sample Output:
3
567
题目大意:有一个正整数,如果它的因数中有连续的数字,输出长度最大的序列,并且输出相关的数字。
分析:无需寻找数字的因数,只要构造连续的数字序列,并查看这些数字的乘积是否为正整数的因数。
代码来自别处:

#include<iostream>
#include<vector>
#include<cmath>
using namespace std;
int main() {
	int n, k, j, temp, len = 0, start = 0;
	cin >> n;
	k = sqrt(n);
	for (int i = 2; i <= k; i++) {
		temp = 1;
		for (j = i; j <= k; j++) {
			temp *= j;
			if (n%temp != 0)break;
		}
		if (j - i > len) { len = j - i; start = i; }
	}
	if (start == 0) { cout << "1" << endl << n; return 0; }
	cout << len << endl;
	for (int i = 0; i < len; i++) {
		cout << start + i;
		if (i != len - 1)cout << "*";
	}
    return 0;
}

欢迎评论!!!

猜你喜欢

转载自blog.csdn.net/ssf_cxdm/article/details/82942720
今日推荐