1096 Consecutive Factors (20 分)

版权声明:SupremeBeast3_ https://blog.csdn.net/weixin_43359312/article/details/89094129

1096 Consecutive Factors (20 分)

Among all the factors of a positive integer N, there may exist several consecutive numbers. For example, 630 can be factored as 3×5×6×7, where 5, 6, and 7 are the three consecutive numbers. Now given any positive N, you are supposed to find the maximum number of consecutive factors, and list the smallest sequence of the consecutive factors.

Input Specification:
Each input file contains one test case, which gives the integer N (1<N<231).

Output Specification:
For each test case, print in the first line the maximum number of consecutive factors. Then in the second line, print the smallest sequence of the consecutive factors in the format factor[1]factor[2]…*factor[k], where the factors are listed in increasing order, and 1 is NOT included.

Sample Input:
630
Sample Output:
3
567

AC代码

#include <iostream>
#include <cmath>
using namespace std;
int main() {
	int N, Maxcnt = 0, Start = 0;	//Maxcnt记录最多连续因子个数 Start记录起始位置
	cin >> N;	//得到数字
	for (int i = 2; i <= sqrt(N); i++) {	//从i开始的连续因子
		int Tmp = N, j = i;	//用Tmp去做处理		//j从i开始
		while (!(Tmp%j)) {		//若i为N的因子
			if ((j - i + 1) > Maxcnt) { Maxcnt = j - i + 1; Start = i; }
			Tmp /= j++;		//除去该因子 同时j自增
		}
	}
	if (!Maxcnt) { cout << "1" << endl << N; return 0; }	//如果无连续因子
	cout << Maxcnt << endl << Start;
	for (int i = Start + 1; i < Start + Maxcnt; i++) cout << "*" << i;
	return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_43359312/article/details/89094129