1096 Consecutive Factors (20 分)

版权声明:本文为博主原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。
本文链接: https://blog.csdn.net/chen_zan_yu_/article/details/102766947

1096 Consecutive Factors (20 分)

Among all the factors of a positive integer N, there may exist several consecutive numbers. For example, 630 can be factored as 3×5×6×7, where 5, 6, and 7 are the three consecutive numbers. Now given any positive N, you are supposed to find the maximum number of consecutive factors, and list the smallest sequence of the consecutive factors.

Input Specification:

Each input file contains one test case, which gives the integer N (1<N<2​31​​).

Output Specification:

For each test case, print in the first line the maximum number of consecutive factors. Then in the second line, print the smallest sequence of the consecutive factors in the format factor[1]*factor[2]*...*factor[k], where the factors are listed in increasing order, and 1 is NOT included.

Sample Input:

630

Sample Output:

3
5*6*7
#include<bits/stdc++.h>
using namespace std;
typedef long long ll;

int main()
{
    ll n;
    scanf("%lld",&n);
    ll sqr=(ll)sqrt(1.0*n);
    ll ansI=0,ansLen=0;
    for(ll i=2; i<=sqr; i++)
    {
        ll temp=1,j=i;
        while(1)
        {
            temp*=j;
            if(n%temp!=0)break;
            if(j-i+1>ansLen)
            {
                ansI=i;
                ansLen=j-i+1;
            }
            j++;
        }
    }
    if(ansLen==0)
    {
        printf("1\n%lld\n",n);
    }
    else
    {
        printf("%lld\n",ansLen);
        for(ll i=0; i<ansLen; i++)
        {
            printf("%lld",ansI+i);
            if(i<ansLen-1)
            {
                printf("*");
            }
        }
    }

    return 0;
}

猜你喜欢

转载自blog.csdn.net/chen_zan_yu_/article/details/102766947
今日推荐