1096. Consecutive Factors (20)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/zs391077005/article/details/79113818


时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Among all the factors of a positive integer N, there may exist several consecutive numbers. For example, 630 can be factored as 3*5*6*7, where 5, 6, and 7 are the three consecutive numbers. Now given any positive N, you are supposed to find the maximum number of consecutive factors, and list the smallest sequence of the consecutive factors.

Input Specification:

Each input file contains one test case, which gives the integer N (1<N<231).

Output Specification:

For each test case, print in the first line the maximum number of consecutive factors. Then in the second line, print the smallest sequence of the consecutive factors in the format "factor[1]*factor[2]*...*factor[k]", where the factors are listed in increasing order, and 1 is NOT included.

Sample Input:
630
Sample Output:
3
5*6*7

提交代码

#include <iostream>
#include <cstdio>
#include <cmath>
using namespace std;
int main() {
	int n;
	scanf("%d", &n);
	int max = sqrt((double)n);
	for (int len = 12; len >= 1; len--) {	//对每一位
		for (int start = 2; start <= max; start++) {	//从2开始缕几个连续的整数
			long long int ans = 1;
			for (int i = start; i - start <= len - 1; i++)	//求乘积
				ans *= i;
			if (n % ans == 0) {
				printf("%d\n%d", len, start);
				for (int i = start + 1; i - start <= len - 1; i++)
					printf("*%d", i);
#ifdef _DEBUG
	system("pause");
#endif
				return 0;
			}
		}
	}
	printf("1\n%d", n);
#ifdef _DEBUG
	system("pause");
#endif
	return 0;
}


猜你喜欢

转载自blog.csdn.net/zs391077005/article/details/79113818
今日推荐