PAT 1037 Magic Coupon

The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product... but hey, magically, they have some coupons with negative N's!

 For example, given a set of coupons { 1 2 4 −1 }, and a set of product values { 7 6 −2 −3 } (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.

 Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

Input Specification:

 Each input file contains one test case. For each case, the first line contains the number of coupons N​C​​, followed by a line with N​C​​coupon integers. Then the next line contains the number of products N​P​​, followed by a line with N​P​​ product values. Here 1≤N​C​​,N​P​​≤10​5​​, and it is guaranteed that all the numbers will not exceed 2​30​​.

Output Specification:

 For each test case, simply print in a line the maximum amount of money you can get back.

Sample Input:

4
1 2 4 -1
4
7 6 -2 -3

Sample Output:

43
#include<iostream>
#include<cstdio>
#include<cmath>
#include<algorithm>
#include<vector>
using namespace std;
typedef long long LL;
bool Compare(int x,int y)
{
    return x>y;
}
int main()
{
    int N,num,index;
    vector<int> x;
    vector<int> y;
    vector<int> u;
    vector<int> v;
    scanf("%d",&N);
    for(int i=0;i<N;i++)
    {
        scanf("%d",&num);
        if(num>0)
            x.push_back(num);
        else
            y.push_back(fabs(num));
    }
    sort(x.begin(),x.end(),Compare);
    sort(y.begin(),y.end(),Compare);
    scanf("%d",&N);
    for(int i=0;i<N;i++)
    {
        scanf("%d",&num);
        if(num>0)
            u.push_back(num);
        else
            v.push_back(fabs(num));
    }
    sort(u.begin(),u.end(),Compare);
    sort(v.begin(),v.end(),Compare);
    LL ans=0;
    int lx=x.size();
    int ly=y.size();
    int lu=u.size();
    int lv=v.size();
    index=0;
    while(index<lx&&index<lu)
    {
        ans+=x[index]*u[index];
        index+=1;
    }
    index=0;
    while(index<ly&&index<lv)
    {
        ans+=y[index]*v[index];
        index+=1;
    }
    printf("%lld",ans);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/ZCMU_2024/article/details/84778414