【PAT甲级】1037 Magic Coupon (25)

题目链接

The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product... but hey, magically, they have some coupons with negative N's!

For example, given a set of coupons {1 2 4 -1}, and a set of product values {7 6 -2 -3} (in Mars dollars M\$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M\$7) to get M\$28 back; coupon 2 to product 2 to get M\$12 back; and coupon 4 to product 4 to get M\$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M\$12 to the shop.

Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

Input Specification:

Each input file contains one test case. For each case, the first line contains the number of coupons NC, followed by a line with NC coupon integers. Then the next line contains the number of products NP, followed by a line with NP product values. Here 1<= NC, NP <= 10^5^, and it is guaranteed that all the numbers will not exceed 2^30^.

Output Specification:

For each test case, simply print in a line the maximum amount of money you can get back.

Sample Input:

4
1 2 4 -1
4
7 6 -2 -3

Sample Output:

43

题意:给定两个长度分别为n,m的序列,从两个序列中选出相同数量的元素两两相乘,求最大乘积之和。

思路:排序后,分别挑出相同个数<0和>0的元素相乘得到结果  注意不要用cin

代码:

#include <iostream>
#include <sstream>
#include <string>
#include <cstdio>
#include <queue>
#include <cstring>
#include <map>
#include <stack>
#include <cmath>
#include <vector>
#include <algorithm>
using namespace std;
typedef long long ll;
typedef unsigned long long ull;
#define rep(i,a,n) for(int i=a;i<n;i++)
#define mem(a,n) memset(a,n,sizeof(a))
#define DBGS() cout<<"START\n"
#define DBGE() cout<<"END\n"
const int N = 1e5+5;
const ll INF = 0x3f3f3f3f;
const double eps=1e-4;

int main() {
    int n;
    scanf("%d",&n);
    vector<int>a(n);
    for(int i=0; i<n; i++)
        scanf("%d",&a[i]);
    sort(a.begin(),a.end());
    int m;
    scanf("%d",&m);
    vector<int>b(m);
    for(int i=0; i<m; i++)
        scanf("%d",&b[i]);
    sort(b.begin(),b.end());
    ll ans=0;
    int i=0,j=0;
    while(i<n&&j<m&&a[i]<0&&b[j]<0) {
        ans+=a[i]*b[j];
        i++,j++;
    }
    i=n-1,j=m-1;
    while(j>=0&&i>=0&&a[i]>0&&b[j]>0) {
        ans+=a[i]*b[j];
        i--,j--;
    }
    printf("%d",ans);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/feng_zhiyu/article/details/81275242
今日推荐