PAT (Advanced Level) Practice 1037 Magic Coupon (25 分)(C++)(甲级)(排序)

版权声明:假装有个原创声明……虽然少许博文不属于完全原创,但也是自己辛辛苦苦总结的,转载请注明出处,感谢! https://blog.csdn.net/m0_37454852/article/details/86503309

1037 Magic Coupon (25 分)
The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product… but hey, magically, they have some coupons with negative N’s!

For example, given a set of coupons { 1 2 4 −1 }, and a set of product values { 7 6 −2 −3 } (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.

Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

Input Specification:

Each input file contains one test case. For each case, the first line contains the number of coupons N​C , followed by a line with N​C coupon integers. Then the next line contains the number of products N​P , followed by a line with NP product values. Here 1≤N​C ,NP ≤105, and it is guaranteed that all the numbers will not exceed 2​30.

Output Specification:

For each test case, simply print in a line the maximum amount of money you can get back.

Sample Input:

4
1 2 4 -1
4
7 6 -2 -3
Sample Output:

43

//本题说到底其实就是求两个数列中数字乘积之和的最大值

using namespace std;
#include<algorithm>
#include<iostream>
#include<cstdio>
#include<cstring>

bool cmp(int a, int b)
{
    return a > b;
}

int C[100010] = {0}, P[100010] = {0};

int main()
{
    int Nc, Np, i, j, money = 0;
    scanf("%d", &Nc);
    for(i=0; i<Nc; i++) scanf("%d", &C[i]);
    scanf("%d", &Np);
    for(i=0; i<Np; i++) scanf("%d", &P[i]);
    sort(C, C+Nc, cmp);//降序排列
    sort(P, P+Np, cmp);
    for(i=0; i<Nc && i<Np && C[i]>0 && P[i]>0; i++)//大于0的部分相乘
        money += C[i]*P[i];
    for(i=Nc-1, j=Np-1; i>=0 && j>=0 && C[i]<0 && P[j]<0; i--, j--)//小于0的部分相乘
        money += C[i]*P[j];
    printf("%d", money);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/m0_37454852/article/details/86503309
今日推荐