1037 Magic Coupon (25 分)排序+贪心

版权声明:假装这里有个版权声明…… https://blog.csdn.net/CV_Jason/article/details/85028967

题目

The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product… but hey, magically, they have some coupons with negative N’s!

For example, given a set of coupons { 1 2 4 −1 }, and a set of product values { 7 6 −2 −3 } (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.

Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

Input Specification:
Each input file contains one test case. For each case, the first line contains the number of coupons N C N_C ​​ , followed by a line with N C N_C coupon integers. Then the next line contains the number of products N P N_P ​​ , followed by a line with N P N_P product values. Here 1 N C , N P 1 0 5 1≤N​_C ,N_P​ ≤10^5 , and it is guaranteed that all the numbers will not exceed 2 30 2^{30}
​​ .
Output Specification:
For each test case, simply print in a line the maximum amount of money you can get back.

Sample Input:

4
1 2 4 -1
4
7 6 -2 -3

Sample Output:

43

解题思路

  题目大意: 给Nc个礼品券(coupons)和Np个货物的价格,求两者相乘求和得到最大正值。
  解题思路: 将礼品券和价格分别用两个vector存储正负值,分别做排序,正数从大到小拍,负数从小到大排,这样既能够避免正数乘以负数,又能够保证乘积得到最大正数 。


/*
** @Brief:No.1037 of PAT advanced level.
** @Author:Jason.Lee
** @Date:2018-12-15
** @status: Accepted!
*/

#include<iostream>
#include<algorithm>
#include<vector>
using namespace std;

int main(){
	int Nc,Np;
	while(cin>>Nc){
		int temp;
		vector<int> coupon_pos;
		vector<int> coupon_neg;
		vector<int> product_pos;
		vector<int> product_neg;
		for(int i = 0;i<Nc;i++){
			cin>>temp;
			temp>0?coupon_pos.push_back(temp):coupon_neg.push_back(temp);
		} 
		cin>>Np;
		for(int i=0;i<Np;i++){
			cin>>temp;
			temp>0?product_pos.push_back(temp):product_neg.push_back(temp);
		}
		sort(coupon_pos.begin(),coupon_pos.end(),[](int a,int b){return a>b;});
		sort(coupon_neg.begin(),coupon_neg.end(),[](int a,int b){return a<b;});
		sort(product_pos.begin(),product_pos.end(),[](int a,int b){return a>b;});
		sort(product_neg.begin(),product_neg.end(),[](int a,int b){return a<b;});
		int sum = 0;
		for(int i=0,j=0;i<coupon_pos.size()&&j<product_pos.size();i++,j++){
			sum+=coupon_pos[i]*product_pos[j];		}
		for(int i=0,j=0;i<coupon_neg.size()&&j<product_neg.size();i++,j++){
			sum+=coupon_neg[i]*product_neg[j];
		}
		cout<<sum<<endl;
	}
	return 0;
} 

在这里插入图片描述

总结

  这道题让我认识了一个新单词,coupon,礼品券……

猜你喜欢

转载自blog.csdn.net/CV_Jason/article/details/85028967
今日推荐