1037 Magic Coupon (25 分)(排序,贪心)

1037 Magic Coupon (25 分)

The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product… but hey, magically, they have some coupons with negative N’s!

For example, given a set of coupons { 1 2 4 −1 }, and a set of product values { 7 6 −2 −3 } (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.

Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

Input Specification:

Each input file contains one test case. For each case, the first line contains the number of coupons N​C​​ , followed by a line with N​C​​ coupon integers. Then the next line contains the number of products N​P​​ , followed by a line with N​P​​ product values. Here 1≤N​C​​ ,N​P​​ ≤10​5​​ , and it is guaranteed that all the numbers will not exceed 2​30​​ .

Output Specification:

For each test case, simply print in a line the maximum amount of money you can get back.

Sample Input:

4
1 2 4 -1
4
7 6 -2 -3

Sample Output:

43

本题大意

给两组只含正负整数的序列,在每个序列中分别取值相乘,每个值至多取一次,使得最终的和值最大。

分析

本题考查排序和贪心算法,具体地是,现将两组序列分别排序,排序规则为正数按从大到小排序,负数按从小到大排序,然后设置两个指针分别指向两组序列的首元素,当两个元素同号时,直接相乘,若两个元素异号,则将整数的那个数舍弃,指针向后移。若存在两元素中存在0时,则简单地将这两个数舍弃,指针均向后移(由于按照简单的处理第一次提交就AC了,但是写这个分析的时候发现,这里是不合理的,可能是PAT没有设置这个测试点,正确的应该是细分若只有一个数是0,则将为0的那个元素舍弃,并将它的指针向后移,若两个数均为0,才按照那个简单地进行处理,这次算是侥幸逃过啦~)

#include <iostream>
#include <vector>
#include <map>
#include <algorithm>
using namespace std;
vector<vector<int> > v;
int getid(char s[]){
    int ans=0;
    for(int i=0;i<3;i++) ans=ans*26+(s[i]-'A');
    ans=ans*10+(s[3]-'0');//(25*26*26+25*26+25)*10+10
    return ans;
}
int main(){
    int n,k,index=1;
    scanf("%d %d",&n,&k);
    v.resize(26*26*26*10+10);
    for(int i=1;i<=k;i++){
        int id,cnt;
        scanf("%d %d",&id,&cnt);
        for(int j=0;j<cnt;j++){
            char name[5];
            scanf("%s",name);
            int tmpid = getid(name);
            v[tmpid].push_back(id);
        }
    }
    for(int i=0;i<n;i++){
        char name[5];
        scanf("%s",name);
        int tmpid=getid(name);
        printf("%s %lu",name,v[tmpid].size());
        sort(v[tmpid].begin(),v[tmpid].end());
        for(auto it : v[tmpid]){
            cout<<" "<<it;
        }
        cout<<endl;
    }
    return 0;
} 

猜你喜欢

转载自blog.csdn.net/whutshiliu/article/details/83041288
今日推荐